Fstab - Mounting Network Drive On Boot Not Working

Hello Everyone,

I am running Manjaro Gnome on my Dell XPS 13 laptop and have been trying to mount a shared drive on my Mac-Mini server with some issues. When I start my laptop (from a cold boot), I see the following output on bootup:

Screenshot:
https://forum.manjaro.org/uploads/default/original/2X/0/0fc7568d10139a4ae4084b043753d360c688d902.png

Fstab Line For Reference:

//asifs-mac-mini.local/asifs\040hd	/home/aahmad/Asifs-Mac-Mini	cifs _netdev,username=aahmad,password=xxxxx 0 0

The issue is that when I boot up, obviously the shared drive is not available. However, when I run the ‘sudo mount’ command, usually it works properly:

sudo mount -va                                                                                                                                                   ✔ 
[sudo] password for aahmad: 
/boot/efi                : already mounted
/home                    : already mounted
/                        : ignored
mount.cifs kernel mount options: ip=10.0.1.100,unc=\\asifs-mac-mini.local\asifs hd,user=aahmad,pass=********
/home/aahmad/Asifs-Mac-Mini: successfully mounted

After executing this command, you can see the mount works and I can access all my files and data on the mac mini server without issue at this point.

The Issue:
I have been told it is a possible issue (since I am on a laptop) that the wifi is not available when the mount is trying to be mounted. However, the error is not very descriptive in terms of what is going on.

Question:
Is there any additional logging / debug information / etc. I can capture so I can be sure this is not another issue behind the scenes that is preventing it from mounting on boot?

Basically, I would like to start my laptop and have the shared mac-mini drive available as outlined in the fstab config mounted to a directory in my home dir location. Any help anyone could offer to help troubleshoot this would be greatly appreciated.

Thanks in advance to everyone for your time and help!

Anyone? Thanks in advance!

For lack of specifc knowledge and experience I can only say this:
I would try to rewrite that as a systemd mount, so that it depends on the network actually being up when the mount is attempted.
Isn’t cifs similar to smb?
I have also read about the “nofail” option to the mount command - so that it doesn’t block when the mount fails.
Just some ideas to explore …

I have a similar issue. Here is my fstab command:

//192.168.0.185/Disk1 /mnt/MyDrive cifs _netdev,x-systemd.after=network-online.target,credentials=/etc/.creds,rw,uid=1000,gid=1000,iocharset=utf8,sec=ntlmv2i,vers=2.0 0 0

My drive is setup on my server as a samba share. When I bootup, file manager gives me permission denied error, however, if i do mount -a command without changing anything, it works. I am using kde version. What am i missing?

Thanks everyone for your help.

@BeatlesFan it maybe because you didn’t execute this command:
sudo systemctl enable systemd-networkd-wait-online

I’m getting the exact same issue as you guys, using KDE also. Have not yet tried bikehunters suggestion, but will give it a go.