Fstab entries are preventing boot


I reinstalled a completely new system and built it from scratch (besides Windows). Everything worked just fine, even though I’m experimenting and trying many things for the first time (also I’m new to Manjaro).
I’m trying to keep a high security standard for a lot of sensitive data, even though maybe the fact I’m not an expert may lead to mistakes in my security architecture.
So I successfully added two external LUKS encrypted drives to fstab and reboots were successful at first. But later, I installed printer drivers, rebooting was not possible anymore without putting hashes in front of the two lines:

# tutorial https://www.golinuxcloud.com/mount-luks-encrypted-disk-partition-linux/
# /dev/mapper/secret                                      /home/marcel/Dokumente   ext4    defaults            0 0 

# /dev/mapper/LUKSbackup2                                 /run/media/backup2       ext4    defaults            0 0

I followed the named tutorial, but I chose different mount points for the drives.

Maybe somebody experienced can see what my mistakes are and tell me how to do it well.

Hello @marcellino :wink:

  1. /run is a tmpfs, what means it only resides in RAM. If the mountpoint doesn’t exist, fstab will fail.

    • Add the option: X-mount.mkdir
  2. Using the block device is inaccurate, since these /dev/sdb1 are assigned dynamically nowadays. Use labels or uuids instead in cryptab.


Dear @megavolt

Thank you for your help. I reconfigured it and it seems to be working.

  1. Instead of /media I mount my backup drive on /mnt/backup2 now, so the tmpfs should not be the problem anymore.

  2. I exchanged the block device with the UUID of the respective drive.

So if anybody might be interested, here are the relevant lines:


# followed tutorial https://www.golinuxcloud.com/mount-luks-encrypted-disk-partition-linux/ 
# used UUID for identifying and not mounted to tmpfs (RAM) /media 
# https://forum.manjaro.org/t/fstab-entries-are-preventing-boot/156533/2
/dev/mapper/data                                      /home/marcel/Dokumente   ext4    defaults            0 0 

/dev/mapper/LUKSbackup2                                 /mnt/backup2       ext4    defaults            0 0


data UUID=69f0d005-9067-4c87-9dde-22c90933af67 /root/lukskey
LUKSbackup2 UUID=0aac98cf-8578-45eb-b017-4beb9b2d4ca8 /root/lukskey_backup2

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.