Fstab cannot mount ntfs drives

I have 2 ntfs disks on my computer and I want to mount them when booting

so I edited fstab like this

/dev/nvme0n1p1          /boot           vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro  0 2
/dev/nvme0n1p3         /home/firestar/C        ntfs    default,noatime 0 0
/dev/nvme0n1p4          /               ext4            rw,relatime     0 1
/dev/nvme0n1p5         /home/firestar/D        ntfs    default,noatime 0 0

then I rebooted and crash into emergency mode, this is the journal:

ThinkPad mount[315]: mount: /home/firestar/C: unknown filesystem type 'ntfs'.

I tried editing /etc/udev/rules.d/ntfs3_by_default.rules: (NTFS - ArchWiki)

SUBSYSTEM=="block", ENV{ID_FS_TYPE}=="ntfs", ENV{ID_FS_TYPE}=="ntfs3"

but the same issue happened

Maybe you are safer with the ntfs-3g

if you want to use the ntfs3 … do you have the ntfs3-dkms from AUR installed?

maybe i’m wrong, but you want to mount the ntfs drive before the root is mounted and probably you also have the home on that / root partition ?


i think the file-system type should be ntfs3 not simply ntfs provided you are using kernel 5.15 or later.

udev rules apply to auto-mounting after booting.

only required if you are using a kernel older than 5.15

1 Like

It seems that the solution is

/dev/nvme0n1p3         /home/firestar/C        ntfs    noatime 0 0

This is not an answer to the question, or any question here, really. It’s just a suggestion. Try using systemd mounts, instead. It works wonders, is easy and I don’t think you’ll crash like you mentioned above.

I think editing fstab is rather over-rated.

Why don’t you edit your fstab - delete the entry, then use something like gnome-disk to mount and write the fstab for you?

I usually grab gnome-disks to do that, then I purge it. I generally go with ‘label’ so that my ‘T2’ disk would be mounted ‘/mnt/T2’ but you can define it easily with gnome-disks.

After this, the step to do systemd mounts is much more trivial.

1 Like

Because GDU usually writes bullsh1t in the file? LOL The few times I trusted it with FSTAB, the system wouldn’t automount the drives upon startup, so I started editing it manually, just like everybody else. Not to mention that GDU doesn’t write things like “no_prefetch_block_bitmaps”.

My advice to the OP - stick to ntfs-3g for now. The driver “ntfs” is still new and has lots of bugs, whereas ntfs-3g may be old but it’s bugs free. I know about the existence of ntfs but I’m still using ntfs-3g because it works as expected.

1 Like

because I do not want to install a software like gnomedisk or kdepartitionmanager

I used to use them but I found out that they do the same thing as editing fstab

Right - that’s your choice.

I haven’t edited an fstab file for a couple of years now - one mistake and it’s a big problem.

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=D6F6-864F                            /boot/efi      vfat    umask=0077 0 2
UUID=24f184f8-2701-427e-b4de-61f31c4ec1b8 /              btrfs   subvol=/@,defaults,discard=async,ssd 0 0
UUID=24f184f8-2701-427e-b4de-61f31c4ec1b8 /home          btrfs   subvol=/@home,defaults,discard=async,ssd 0 0
UUID=24f184f8-2701-427e-b4de-61f31c4ec1b8 /var/cache     btrfs   subvol=/@cache,defaults,discard=async,ssd 0 0
UUID=24f184f8-2701-427e-b4de-61f31c4ec1b8 /var/log       btrfs   subvol=/@log,defaults,discard=async,ssd 0 0
UUID=24f184f8-2701-427e-b4de-61f31c4ec1b8 /swap          btrfs   subvol=/@swap,defaults,discard=async,ssd 0 0
/swap/swapfile                            swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/disk/by-partlabel/W10 /mnt/W10 auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=T4 /mnt/T4 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-partlabel/NTFS /mnt/NTFS auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=T3 /mnt/T3 auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=W2 /mnt/W2 auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=NTFS /mnt/NTFS auto nosuid,nodev,nofail,x-gvfs-show 0 0

It only takes seconds to use gnome-disk to set the mount, then purge it - and it never made mistakes for me… but you’re here because your fstab isn’t working. My solution to that is to delete all of the extra mounts and have the fstab re-generated for me.

It worked for me for 3 years now - I have a Windows 10 plus an NTFS shared storage partition and never any issues - also I have no ‘ntfs-3g’ in there…

but you do it your way :wink: I’m sure it’s better.