Frustration features need disabled on mouse- 'wheel click'

Just a plain ordinary ONN bluetooth mouse with as few buttons as I could find.
Left, right, and wheel in center.
Unfortunately the bored designers at ONN decided to incorporate a ‘wheel-click’ easter egg feature which is the worst annoyance ever. Essentially you accidentally and repeatedly click down on the wheel while using it, and this is emulated as a left button click, which is never what you intended to do.
How to turn off/disable this demon?
I’m assuming its set in a device file somewhere in Manjaro, because the GUI mouse configuration has no such setting to turn OFF.
Can anyone help?

I figured it out. Whew

Hi, could you please share the solution?


Hi sure. I created a short linux script. I tried having it launch automatically at boot, but it seems to keep coming back occasionally anyway.
So I go out to a prompt and type ‘nomiddle’ to turn it off.
Wish I could just open up the mouse and yank the wire, lol.

/usr/local/bin $ cat nomiddle
# Let’s find the wily mouse number first:

mouse_number=xinput | grep Mouse | awk ' { print $7 } ' | cut -c 4-5

xinput set-button-map $mouse_number 1 0 3

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.