Frozen Desktop issue

Hey there friends.

I was just messing around with the KDE taskbar settings, dragging new widgets in etc., and was suddenly kicked out of the edit menu and the whole thing locked up. I immediately rebooted and that did not fix the issue, the taskbar(s) are there but completely uninteractable, even the clock is stopped. Right-clicking on the desktop doesn’t pull up a context menu to re-enter the edit mode, and the Alt+D, Alt+S shortcut I found online isn’t working either. Certain other global shortcuts seem to be broken too, but not all of them. How can I get out of this? Thanks in advance.


Bottom half of the right edge is supposed to have an auto-hide taskbar.
Side-note can someone explain what the grouping widget is supposed to do? None of the widgets I put into it actually function. Kinda feeling it might have caused the crash as well.

System Info

Kernel: 5.10.109-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=b372f6d7-b299-4755-bfeb-f9b21ff8ab3c rw quiet apparmor=1
    security=apparmor resume=UUID=e8af64ed-62a4-40f2-b41d-f3e0ce63bfe1
    udev.log_priority=3 intel_iommu=on
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X570 Phantom Gaming 4S
    serial: <superuser required> UEFI: American Megatrends v: P2.60
    date: 04/08/2020
  Message: No system battery data found. Is one present?
  RAM: total: 15.62 GiB used: 3.21 GiB (20.6%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2267 high: 3598 min/max: 2200/4335:4461:4208:4714:4588
    boost: enabled scaling: driver: acpi-cpufreq governor: schedutil cores:
    1: 2235 2: 1976 3: 2169 4: 2211 5: 2194 6: 2197 7: 3598 8: 2032 9: 2009
    10: 2200 11: 2200 12: 2192 bogomips: 86439
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme smep ssbd sse
    sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
    topoext tsc tsc_scale umip v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Micro-Star MSI driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 0c:00.0
    chip-ID: 1002:731f class-ID: 0300
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Acer SB220Q serial: <filter>
    built: 2020 res: 1920x1080 hz: 75 dpi: 102 gamma: 1.2
    size: 476x268mm (18.74x10.55") diag: 546mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.40.0
    5.10.109-1-MANJARO LLVM 13.0.1)
    v: 4.6 Mesa 21.3.8 direct render: Yes
  Device-1: Creative Labs CA0108/CA10300 [Sound Blaster Audigy Series]
    driver: snd_emu10k1 v: kernel bus-ID: 05:00.0 chip-ID: 1102:0008
    class-ID: 0401
  Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab38
    class-ID: 0403
  Device-3: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-4: JMTek LLC. TKGOU PnP USB Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-4:4 chip-ID: 0c76:1467
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.10.109-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes

go to system settings/appearence/global theme - check use desktop layout from theme, click defaults, then apply - if you cant open systemsettings, open them with terminal - type:
if it doesnt work try this:
rm -rf ~/.cache/*
rm ~/.config/Trolltech.conf
kbuildsycoca5 --noincremental

Thanks so much for your reply, unfortunately none of that worked. :frowning:

In case it’s relevant here’s the content of Trolltech.conf (after running your instructions)

Palette\active=#232629, #fcfcfc, #ffffff, #f6f7f7, #888e93, #c4c8cc, #232629, #ffffff, #232629, #ffffff, #eff0f1, #474a4c, #35bfa4, #ffffff, #2980b9, #9b59b6, #f7f7f7, #000000, #f7f7f7, #232629, #232629
Palette\disabled=#a0a1a3, #f0f0f0, #ffffff, #ebedee, #82878c, #bbc0c5, #aaabac, #ffffff, #a8a9aa, #f3f3f3, #e3e5e7, #474a4c, #e3e5e7, #a0a1a3, #a3cae2, #d6bae1, #ebebeb, #000000, #f7f7f7, #232629, #232629
Palette\inactive=#232629, #fcfcfc, #ffffff, #f6f7f7, #888e93, #c4c8cc, #232629, #ffffff, #232629, #ffffff, #eff0f1, #474a4c, #75f2da, #232629, #2980b9, #9b59b6, #f7f7f7, #000000, #f7f7f7, #232629, #232629
font="Noto Sans,10,-1,0,50,0,0,0,0,0"

Also wanted to note that if I check “use desktop layout from theme” and then click defaults, it unchecks the box. I did attempt doing that and hitting apply but when that didn’t work I did it in the other order, which still didn’t work.

so create a new user and log with it and test if there is also freeze

Hi, thanks again for the quick reply, and sorry mine are so slow.

New user does not freeze.

so in the ‘frozen’ user in the home folder rename the .config folder to .config.bak and reboot and see if it helped with the freezes… the config folder is going to be recreated, so dont worry

Damn I was hoping we wouldn’t have to go that far but yea that fixed it. Thanks for your help.

you can copy from the config.bak folder into the new .config folder your program folders, for example from the browser, libreoffice, the autostart etc… just dont copy any kde/plasma configs so that you dont reintroduce the issue again…

Awesome, thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.