From PulseAudio to PipeWire for Elgato USB MIC [Manjaro KDE 21.1.6]

Hello everyone!

I’m a new user here an finally a proud owner of a Manjaro KDE under 5.15.6-2 kernel :heart_eyes:
Almost everything works perfectly except for my USB Microphone: Elgato Wave 3. Browsing this beautifull forum, i noticed people were suggesting to switch from PulseAudio to PipeWire, and that’s what i did, following exactly this guide: Manjaro-KDE Pipewire install, removing pulseaudio - YouTube
I followed step by step everything and the microphone still doesn’t work. :thinking:
Now, i know that sometimes stuffs works differently on Linux compared to Windows, and most of the time the system require manual edits, but i don’t understand why the microphone isn’t capture by OBS or Discord. While browsing, someone suggested to check if everything is installed correctly, and i checked,this is the result:

pactl info                                                                                                                                                                                                 ✔ 
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 103
Tile Size: 65472
User Name: nonamefound
Host Name: linux-rig
Server Name: PulseAudio (on PipeWire 0.3.40)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.usb-Elgato_Systems_Elgato_Wave_3_BS45J1A05279-00.analog-stereo
Default Source: alsa_input.usb-Elgato_Systems_Elgato_Wave_3_BS45J1A05279-00.mono-fallback
Cookie: 1bb7:c0cd

Seems, for the output i got from Konsole, everything must be fine, but still doesn’t work :frowning: Keep in mind guys that i’m new to Linux (even if i’m a PC technician since more than 20 years)i can do basically everything on win but on linux my audio (microphone only) isn’t working. Maybe i skipped to install some packages or maybe i’m missing something,simple because i miss the basic knowledges how the audio works in linux. Every help would be greatly appreciated, and i wanna also make a donation for this project, because this OS must go further, for sure, i’m addicted to it, and if there’s a possibility i can switch permanently on this one, noone can be more happy than me. :heart_eyes:
If you need some informations do not esitate to ask, i will do my best!

Thanks a lot guys, and keep it up this wonderfull project that deserve MORE!


Wondering if i need to install additional packages for PipeWire, can be the issue maybe?

Thanks everyone

I’m using pipewire on 4 machines that I run Manjaro KDE on and to switch to pipewire, one needs nowadays only run (worked fine for myself last I tried):

pamac install manjaro-pipewire

I’d add the wireplumber package myself to the command to use that as the sound session manager but it’s not mandatory at this time but rather a future development of Pipewire.

You do have the sound sink and source listed but a quick googling suggests that the Elgato Wave 3 may be problematic to use, Wave 3 on Linux : elgato.

I do not know if anyone has gotten the Wave 3 to work without issues.Personally I use the Yeti X which has been quite problem free.

First of all, thank you so much jpalko for your answer! :wink:
What this guy wrote is absolutely true: it’s really difficult, if not impossible to make it work under Linux (any distribution/any kernel) because the hardware is made to host multiple virtual audio channel, and at the end Alsa being confused and don’t know what to do. Will try what you suggest, but to be completely honest with you, i don’t have any hope.
I got the YetiX back in the days, and i gifted to a friend who started streaming like me because i’ve upgraded my setup with a combination of go-XLR (impossible to make work on linux) + an XLR microphone. So, seems i’m hopeless :joy:
Again, thank you so much for your time,greatly appreciated.

1 Like