From PlugnPlay to disarray with ZTE USB 4G gizmo

ZTE WCDMA Technologies MSM DEMO Mobile Boardband (sic) is what lsusb identifies it as. It’s on loan from SFR (I’m in France) until they can find the problem with our landline and fix it. It’s a tiny little gadget that piggy-backs on the SFR 4G network and provides a wireless access point to all our needy devices. It’s also able to be plugged into a desktop pc to provide internet access, and last night, when we got back from the shop, that’s what it did: I plugged it into my Manjaro Gnome desktop (recently reinstalled and system up to date) and I was somewhat gobsmacked that it was immediately recognised, showed up in the network settings and I was back on the net. (A relief, as I don’t have a USB wireless adapter). But this morning, plugging it in again, zilch! It still shows up with lsusb, but no sign in the network settings and I’m at a loss how to re-initialise it. Any helpful ideas would be very welcome.

Those devices often operates in modes - one mode provides CD file system with drivers etc an another provides an interface to the network.

I have never had such device - so I don’t much - you could try with usb_modeswitch - available in the repo - a lousy suggestion when I don’t even know how to use it - or if it is necessary.

Thanks anyway.

something I found on the matter:

Mobile broadband modem - ArchWiki


usb_modeswitch(1) — Arch manual pages

It has been a very long time since I had a device that needed to be switched from one mode to the other like that.

1 Like

Thanks for that, and sorry for the delayed reply - been involved in another troubleshooting issue!

Atm, I can’t get my main desktop online, so can’t install anything that might help me get back online - Catch22! But once the service is back up (technician came yesterday and said he’d fixed it, left before it reset, and when it reset, still no Internet!) I’ll be looking to install a few tools like that as insurance against future issues. Should probably get a Wi-Fi d’ongle for that computer too!