Fresh Manjaro USB SSD install works on another laptop, but not mine

I have a HP laptop and I have installed Manjaro on a USB SSD drive (partitioned with gparted and chose manual partitioning).
On the HP laptop, Manjaro is not visible at boot (secure boot is disabled, legacy boot doesn’t change the outcome), but on another laptop (Asus), Manjaro is booting and runs perfectly.

fdisk -l /dev/sda

Disk /dev/sda: 223,57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: ED600
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xf025db96

Device     Boot    Start       End   Sectors  Size Id Type
/dev/sda1  *        2048    514047    512000  250M ef EFI (FAT-12/16/32)
/dev/sda2         514048  61954047  61440000 29,3G 83 Linux
/dev/sda3       61954048 468856831 406902784  194G  7 HPFS/NTFS/exFAT

gdisk -l /dev/sda

GPT fdisk (gdisk) version 1.0.5

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present

Found invalid GPT and valid MBR; converting MBR to GPT format
in memory.

Disk /dev/sda: 468862128 sectors, 223.6 GiB
Model: ED600
Sector size (logical/physical): 512/4096 bytes
Disk identifier (GUID): 89BB6F57-11BD-4C2A-A744-95E7FC47E0D9
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 468862094
Partitions will be aligned on 2048-sector boundaries
Total free space is 7277 sectors (3.6 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          514047   250.0 MiB   EF00  EFI system partition
   2          514048        61954047   29.3 GiB    8300  Linux filesystem
   3        61954048       468856831   194.0 GiB   0700  Microsoft basic data

You have created a portable installation?

Which works with one system - but not another?


After I posted the question, it seems I use MBR as disk’s partition table. The HP laptop might not support MBR as it’s fairly new.
I ran sgdisk -g /dev/sda on the drive (converting MBR to GPT), making it unbootable. It seems I have to reinstall the boot loader. Which I don’t know how to do.

LE: I have manually installed the boot loader like this tutorial explains. But no luck, it’s still unbootable.

LLE: I have wiped the drive, selected GPT as partition table and reinstalled Manjaro with the same partitions, but this time the partitions were made with the setup partitioner. Same issue.

The firmwares compatibility mode which can confuse even a seasoned Linux user a great deal.

The fact that it is even there is against the overall principle - enforced by Microsoft - of securing the operating system from being tampered with.

Because I believe it won’t work without disabling secure boot.

@linux-aarhus The secure boot is disabled (I mention it in the first post). :slightly_smiling_face:

GPT-Installation willl not start on MBR-Machine?

What I meant is the laptop which don’t boot - ensure compatibility mode is enabled when you are using MBR formatted media to load the operating system.

Generally a GPT install does not boot on BIOS/MBR system.

You can boot a GPT installation on MBR only using GRUB and only using an unformatted partition of the BIOS boot Partition Type ID 0xEF02 and contrary to what you may have learned on GRUB install using MBR you must install grub to the bios boot partition.

1 Like

@GaVenga I don’t use a MBR only machine.

@linux-aarhus by compatibility mode, I hope you refere to “Legacy support enable”. Because this is the only option in BIOS that sounds remotely like that. With it enabled or disabled, it doesn’t change the outcome.

Screenshot of “Secure boot configuration”:

Screenshot of “Boot options” when the USB SSD is inserted:

Screenshot of “Boot options” when the USB Manjaro Live stick is inserted:

As you can clearly see, the USB SSD is not visible on “UEFI boot order” like the its counterpart USB Manjaro Live stick.

Legacy support and Compatibility mode is the same thing

That is because it is not an EFI boot media and logically it cannot be listed in EFI boot order.

So the option: “Legacy Support Enable and Secure Boot Disable” is correct
(On my ASUS-Machine its the same, (Win10 and Manjaro in UEFI mode))

You are hijacking the thread - please don’t.

1 Like

@linux-aarhus What did I do wrong then? And how can I set EFI to the USB SSD?

@GaVenga With either “Legacy Support Enable and Secure Boot Disable” or “Legacy Support Disable and Secure Boot Disable”, the USB SSD still cannot boot.

There is no easy answer to that.

Partly because I think we are circling - an xyproblem - the underlying issue is the lack of understanding of the difference between BIOS/MBR and EFI/GPT.

Depending on the type of USB device it may report itself as REMOVABLE and installing Manjaro to a removable device must be done manually and special caution is needed both with the fstab generation and the boot loader installation.

There is several topics on how to target a removable device for installation. Just search the forum - one of them is this

Please familiarize yourself with the subtle differences as I am quite sure this is where the real issue is.

1 Like

@linux-aarhus I understand how BIOS/MBR and EFI/GPT work (in theory), but all my installs (in the span of the last 10 years) used MBR with GRUB. I never had issues with them. I even experimenting removing the boot loader on purpose, then put it back. Never had issues.

Now I have installed Manjaro the way you described (without the encryption and I used XFCE instead of LXDE). But, still, on the HP laptop it doesn’t see it. However, besides the Asus laptop, now it boots even from a non UEFI machines (I tried it on another old laptop that supports only MBR, that previously didn’t boot from the USB SSD).

So, I guess, the problem is the laptop, somehow… but I wonder: why/how does the Live Manjaro stick work?! Could you explain how it’s made bootable?

==> boot-device is not internal, but on USB-port…
BIOS: something like “boot-device HDD / boot-device-FFD”?
Your Live-USB is recognized, but “Manjaro-SSD” not;
Does the “Manjaro-SSD” show up in BIOS “Boot-Configuration”?

BIOS: something like “boot-device HDD / boot-device-FFD”?

I didn’t find anything like that in BIOS.

Does the “Manjaro-SSD” show up in BIOS “Boot-Configuration”?

Scroll a bit up. Find the post with the screenshots, the third one has the Live Manjaro stick plugged in.

Use Partition-manager: gparted.
If the “Manjaro-SSD” is UEFI - there will be a partition named “/boot/efi” formatted with fat32.
A Live-USB shows up as “iso9660” and “MISO_EFI” to boot.
Setting “USB-SSD” to EFI is too difficult. Better backup valuable data and create “USB-SSD” installation new:
Create a Live-USB, select in boot-menu a start-device called UEFI-xxxx - (should be the live-usb) and try to start
on both machines. If one refuses to start, or does not show the option UEFI-xxx, thats no good.
If usb-live starts on both machines in UEFI-Mode you can install Manjaro on the USB-SSD…

deepin-boot-maker - has somebody tested this?

Boot-Options? I see, not showing [UEFI]-Sandisk Cruzer Blade …"
means you can not start in UEFI mode on this laptop…
The Live-medium can start as UEFI - AND/OR - MBR so on this Laptop it chooses MBR-start…
So the Tipp of linux-aarhus is the best to do:

@GaVenga I tried gparted and with built-in installation partitioner, as I said. No luck.

And I already tried linux-aarhus tutorial, check a few posts up, and it managed to boot on a non UEFI laptop, which it didn’t boot previously. But the dang HP laptop still doesn’t see it.