Fresh Install Today - Mouse Wheel Scrolling Does Not Switch Virtual Desktops?


I’m still using Xfce on one desktop but am unhappy with it somewhat.
(desktop customization is lacking compared to KDE)

Installed current Manjaro KDE 64Bit onto another desktop but am having problems:

  • Fresh install today - mouse wheel scrolling does not switch virtual desktops?

Any ideas?
(this worked some time ago when I last looked at KDE)


If you mean mouse wheel scrolling on an open spot on the desktop, check whether that’s enabled. Right-click the desktop and choose “Configure Desktop and Wallpaper”, and then click on “Mouse Actions”. If the action of scrolling over the desktop is not listed there, then you can easily add it.

Other than that, you can also use the scroll wheel over the desktop pager in the panel.


Yes, I checked “Mouse Actions” and it is set to default.
Any other ideas?
(this is a deal-breaker for me)


The scroll wheel entry in that list should be set to “switch desktop”. Try changing it.

It was and is set to that


Found a work-around, it now works, thanks!
Desktop Settings->Layout must be set to “Desktop”…



Well that’s not good, can’t have icons on the desktop

I have the same problem.
Its still broken.
Thanks for posting workaround & link to KDE bug report. Workaround does the trick.
BTW running kubuntu 20.04. No problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.