Fresh Install - SSD Drive Missing After Reboot, But SSD There After Cold Boot?


Just installed Manjaro KDE onto a new SSD in my Lenovo laptop.

Everything is ok, but when rebooting the SSD drive is missing and the Manjaro does not boot?
Cold boot correctly shows SSD drive and Manjaro boots fine?

I tried fresh installs with both UEFI and Legacy and same result?
Lenovo laptop BIOS is up-to-date.

Any ideas?


System configuration is below:

  Kernel: 5.16.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: KDE Plasma 5.23.5 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20351 v: Lenovo G50-70
    serial: <superuser required>
  Mobo: LENOVO model: Lancer 5A2 v: 31900058WIN
    serial: <superuser required> UEFI-[Legacy]: LENOVO v: 9ACN32WW
    date: 07/20/2015
  ID-1: BAT0 charge: 16.3 Wh (100.0%) condition: 16.3/28.5 Wh (57.0%)
    volts: 16.3 min: 14.4 model: Lenovo IdeaPad status: Full
  Info: dual core model: Intel Core i5-4210U bits: 64 type: MT MCP
    arch: Haswell rev: 1 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 1289 high: 1696 min/max: 800/2700 cores: 1: 797 2: 968
    3: 1696 4: 1696 bogomips: 19161
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
    v: kernel bus-ID: 00:02.0
  Device-2: Acer Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 2-6:4
  Display: x11 server: driver: loaded: modesetting
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0
  Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.16.2-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Lenovo driver: ath9k v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb
    v: 0.8 bus-ID: 2-7:8
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 465.76 GiB used: 12.63 GiB (2.7%)
  ID-1: /dev/sda vendor: Samsung model: SSD 870 EVO 500GB size: 465.76 GiB
  ID-1: / size: 448.71 GiB used: 12.63 GiB (2.8%) fs: ext4 dev: /dev/dm-0
    mapped: luks-46e4e806-1d42-4d61-bdb0-8cfaee4a94a2
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/dm-1 mapped: luks-ffc76c44-1f66-4bbf-8843-89ff26a5075c
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 202 Uptime: 25m Memory: 5.69 GiB used: 1.64 GiB (28.9%)
  Init: systemd Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1274
  Shell: Zsh v: 5.8 inxi: 3.3.12

When you reboot, try using this command instead of the Menu Restart: sudo shutdown -r now

I had the same issue on an MSI Bravo 17, which I gave to my son, but he is running Windows so I never did find the problem. But I did notice that if I used that command to restart, the SSD always showed up. If not, a cold start was the only way to have the SSD show up again.


Thanks for the reply…

I tried above command, but still no SSD drive after reboot?
Works every time I cold boot though.

The Lenovo Laptop was a throwaway and I added a new Samsung SSD drive.
Works fine otherwise, thanks!


I can almost guarantee it is not the SSD, I switched the boot SSD’s on mine and it did the same thing. If you still have the USB install, I would try it, and see if it reboots fine with the USB installer, if it does work, then you know it is something in your system. That’s about all I can offer, run through the logs and see if anything shows up.

Have you tried another kernel ? like 5.10, 5.15

If you use encryption you should mention it. :face_with_raised_eyebrow:

1 Like


Sorry, I thought it was obvious in my second post that I use encryption.
Anyone else have any ideas?


Check BIOS options for the hard drives. Try to fiddle with it. Also check if there’s come option in the BIOS like fast restart or something similar.


Looked again at BIOS - “Fast Boot” is already disabled.