Fresh install on old Laptop with new SSD - general feedback

Hi Manjaro Team,
Happy new year!

This is some general feedback about a fresh install on a new SSD (870 EVO) inside a Thinkpad T60, 64Bit, Core 2 Duo T5500, Intel Graphics i915, 2GB RAM only. So maybe a little bit under-specced.

Manjaro KDE 23.1.2 Vulcan, Kernel 6.6, installed via minimal ISO on bootable USB.

Ideal goal: a minimalistic KDE only system, which is easy on HW.


  • After manual partition with GPT/BIOS, the installer froze at the warning popup about the unformatted 8GB partition. Pulling the plug and restarting solved the problem.
  • Just by selecting Amsterdam as the city in the time zone dialogue, I ended up with Dutch language. Locale was expected to be set to British. Correcting language/locale was a total mess and needed several reboots/login-cycles.
  • Graphics and especially external USB-Audio did work out of the box. :slight_smile:

User Experience:

  • This T60 is partially overwhelmed by the HW requirements, especially …
    • RFE: for KDE there should be button for a minimum of animations, minimum stress on the GPU, it took ages to click through all the KDE Workspace / Window / Animation dialogues, that could be an option of the installer.
    • “Add/Remove Software”, starting from “Minimum ISO”:
        • Search is saturating the OS for a minute, RAM requirements are enormous! ;(
        • Mirrors needed to be set manually to the local ones, that caused some extra delays
    • Firefox is a hog,
    • Manjaro Forums does not run in Konqueror or Falkon, :wink:
    • RFE: KDE Falkon is not included in the minimum ISO; highly recommended.
    • QTWebEngine is going haywire sometimes at 100% CPU for no apparent reason.
    • "kioslave5 (Disk Sleep) " was blocking one single random file (which was not touched before) according to lsof, as a consequence of which was preventing an external USB-HDD from ejecting. The HDD was mounted and fully functional in Dolphin. Only a reboot could solve this.

In general the 23.1.2 Vulcan system on the new SSD is running a bit faster with less odd bugs, fe. the “old” and updated Konqueror was exhibiting previously.


I think GPT/BIOS doesn’t really fit together.

You should use MBR/BIOS or just use GPT/UEFI, i use GPT only on non-boot drives as long i use Legacy BIOS.

You are running the wrong setup for very slow systems. I had a very old i915 celeron system that i could not get to work acceptably with anything besides MATE desktop with “hybrid rendering” selected through mate-tweak. It was way faster than lxde/qt. I did not however try tiling WM:s like i3 or awesome, so they also would probably work. And i tried E17 DE and it worked well, but it’s pretty quirky.

For such old hardware - you should definately use a system with xorg and window manager only.

lxqt will run fairly smooth - for web browsing - something light like falkon would probably do ok - perhaps chromium too.

And - as your system only has 2GB ram - my immediate thought is you should use a 32-bit system - some Debian based distributions still provide 32-bit and archlinux 32-bit also exist.

If you would appreciate a fresh build of mate or lxqt you can find unofficial iso in one of my archives at linux-aarhus archive @

Even Debian is thinking of abandoning 32bit Debian preps ground to drop 32-bit x86 as a separate edition • The Register

That had to come at some point …

Try Mabox Linux - it is manjaro, stripped from DE and requiring about 400mb RAM.

And the link Mabox Linux

Fast, lightweight and functional Linux Desktop, “relaxed” rolling-release, Manjaro based with Openbox Window Manager