Fresh install of Manjaro not booting on new AMD system - Ryzen 5000 series need kernel 5.9

Hello everyone, I am relatively new to the world of Manjaro. I have heard good things about the OS, and I was looking to try it out for myself on my new PC. I recently just tried to install Manjaro with the XFCE environment using the ISO named: manjaro-xfce-20.1.2-201019-linux58.iso

The installation process looked like it worked, and it seemed to run fine off my USB stick that I used to install Manjaro, but I can’t get the installed OS to boot and I am a bit stuck on resolving the issue.

When I try to boot from grub, it fails to load, ending with the message [FAILED] Failed to start Load/Save RF Kill Switch Status.

Thankfully, I use rEFInd as a boot manager since I run a couple of other distros alongside Windows already, and I was able to try an alternate boot option which ended on EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?) . I can also start a root session in terminal mode with this other boot option that I found, so I can obtain further diagnostic information if need be.

When I went to look up the second error, I saw some stuff about other systems using AMD processors having similar issues. I suspect I’m having either a problem with the chipset, or a problem with my current CPU, which is one of the newest Ryzen models. I’d just like some sort of confirmation that this is the sort of problem I am having, and if there’s anything I can do to help get Manjaro working with my hardware I am open to that.

My current system specs are:
CPU: AMD Ryzen 7 5800X
Motherboard: ASUS ROG STRIX X570-F Gaming
RAM: 32GB DDR4-3600 G.Skill Trident Z RGB
GPU: Nvidia GTX970 (currently waiting for an RTX 3080)
OS Drive: XPG GAMMIX S50 Lite 1TB M.2 2280 PCIe Gen 4.0 NVMe 1.3
Boot Configuration: In a multi-boot system with Windows 10, Ubuntu, and Fedora, using rEFInd as the boot manager.

Yeah I am going to guess you need the latest kernel.
But … if Ubuntu and Fedora work …

Should I just try redownloading the ISO, flashing it to USB, and then try again, or is there something I can do during installation to make sure that the latest kernel is being installed?

The ISO’s are written with the kernel there.
What kernel are you running Fedora on ?

Running the command uname -r in the Fedora terminal gives me:


You could maybe try the RC image:

So I have just tried installing using the RC image and I got a new error:

Command 'grub-mkconfig -o /boot/grub/grub.cfg' returned non-zero exit status one

Final update: I have resolved this issue by just wiping the Manjaro partition and trying again. This version works now. Thanks so much @cscs for pointing me to this iso!

Oh thats great to hear. Cheers. :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.