Fresh install of manjaro-kde-20.1-rc5, after install video-nvidia-450xx and reboot, black screen

As the title says, I have done a fresh install of manjaro-kde-20.1-rc5 and after install video-nvidia-450xx and reboot, black screen with Acer logo instead of login screen.

Bellow some screenshots I have made.


That is quite normal to happen if you just installed the video-nvidia-450xx driver, without doing the rest of required configurations for that. You should have had installed the video-hybrid-intel-nvidia-450xx-prime since is a hybrid GPU laptop.
Might take a look at this in the archived forum:

Can you get into tty after booting by press ctrl + alt + [f2, f3, ... , f6] ?

I reported on forum because I already installed several versions of Manjaro on this laptop, always without any problem. I mean, fresh install of ISO, followed by updates (if any) and then using the graphical tool to install the nVidia driver always worked. This time, doesn’t.

Yes, tried some tips from other posts without success. Maybe next ISO or some update will make things works nice as in my previous installations.

Then you can try mhwd -li To check the drivers installed
and mhwd -r pci *driver-name* to uninstall the driver
and mhwd -i pci *driver-name* to reinstall it.

Actually I once tried Jonathon’s solution to deal with external monitor problem but get black screen, didn’t know why, maybe I made some mistakes :frowning:

Switch to kernel 5.7 or 5.4

Alternatively, you can reinstall - update the kernel to 5.7 (I’ve had issues with 5.6 when auto installing proprietary drivers - probably because the kernel version that shipped with the ISO is unsupported, at least the - quite recent - ISO I had laying about on my system) then select auto install proprietary drivers - this way it will most probably install the hybrid 450x version on it’s own with no further issues.

Just done a fresh install of endeavouros-2020.07.15-x86_64.iso and it worked without any problem, like all previous versions of Manjaro.

It’s something in this RC5 of Manjaro 20.1…

Tried to attach a screenshot but “Sorry, you can’t embed media items in a post.”. :expressionless:

Nvidia GTX970M on MSI Laptop with latest kernel and driver no problem with optimus manager. Follow the guide and delete nvidia config in /etc/x11