Fresh Install of Manjaro i3 on VMware player 15 not providing transparancy


So I’ve just installed Manjaro i3, and I am trying to get some transparency on things (terminal would be the main one).

In Konsole (old KDE user here), when i set the transparency there is popup that says

“The background transparency setting will not be used because your desktop does not appear to support transparent windows.”

In the past, installing i3 manjaro in VMware player always gave me transparency without having to fiddle with anything?

Anyone have any idea how I can go about fixing this?
Sorry English is not my first languarge!

-k swain

I believe you need to adjust the picom/compton config. I’m not on my manjaro-i3 machine right now, but if that’s not enough info for you then I can look up the specifics when I get home.

1 Like

ah ok, thanks for the quick reply! Ill google around more now that I have the ability to be more speciific! I will let you know here if I can fix it and if not we go from there?


Hmm, I have found the picom.conf (there’s also a picom.conf.example which is larger and different?) in the /etc/xdg/ directory, and i see only a passing mention of transparancy in there. Nothing that seems like it would allow the entire system to have or not have any transparancy… Also doesn’t seem like many people have had this issue after googling around for it…

Yeah, I’m looking at my ~/.config/picom.conf and trying to remember exactly what I did. Check out the Opacity section in the Arch Wiki entry for picom; I think that’s what did it for me.

EDIT: Also, make sure there’s a `exec --no-startup-id picom -b’ somewhere in your i3 config.

1 Like

Did both of those things:

  1. added the following to picom.comf

    opacity-rule = [
    “90:class_g = ‘URxvt’ && focused”,
    “60:class_g = ‘URxvt’ && !focused”

  2. added ‘exec --no-startup-id picom -b’ (no quotes)

And even did a full reboot, and still nothing.

If you’re using Konsole then you should probably change URxvt to konsole in those lines, at least I assume. And you’ve got transparency set in the konsole config (or preferences or whatever it uses)?

Also, have you changed the opacity setting in the wintypes function near the bottom of picom.conf? If you’re not sure what I mean then look at this guy’s setup.

1 Like

Ah yeah, i had just pasted the that from the arch-wiki example, i changed it to konsole for my actual file. Ill keep messing with it, thanks again for the tips!