Fresh install of 20.2 - Slow shutdown

Hello team -

I installed 20.2 Gnome yesterday on my four-year old System76 machine and everything seems to work well except the shutdown. Seems like it takes several minutes though I’m not especially busy and close out all known apps before the shutdown.

I’m not sure how to troubleshoot. I’m not a technical user but did look for earlier posts and wasn’t sure what to take away. Your thought welcome.


FYI, there is an extra HDD installed (but not running) on this machine. As far as I can tell that drive isn’t mounted but the system does present a dual-boot screen when I start.

Try this:

Hey Wollie -
Thx for the reply. I added that to the bottom of the file mentioned (shown below). Worked once. Other times no. But appreciate the response.

I had problems with slow shutdown times too, even though my installation runs on an SSD. I installed “haveged” and ran these commands:
sudo journalctl --flush
sudo rm -r /var/log/journal
I also enabled Storage=auto in /etc/systemd/journald.conf
After I did this, shutdown was almost immediate.

1 Like

I notice slow shutdown when steam is running. If i stop it before it goes way faster :thinking:

How I solved the issue that takes me 3-5minutes to shutdown was to disable the Restore previous session on login.

Settings → Workspace → Desktop Session → On Login → [selec] Start with an empty session

my shutdown now takes only 15-20 seconds

Hope it helps your issue.