Fresh install has problematic scaling

I just brought a new laptop (Thinkpad). I downloaded the latest KDE normal ISO (2126) and chose proprietary drivers (have nvidia GPU), and booted up the live disk. But everything looks… terrible. This is a 16" 2560x1600 display.

I didn’t change the window sizes, fonts, scaling, or anything. I just booted to USB, chose proprietary drivers, and opened some windows.

The cursor is too small, everything in Firefox is too small, all the other fonts are too big in proportion to the display, and the windows which do attempt to scale, like the Manjaro installer, are way too small with different elements of the program truncating and overlaying where they shouldn’t.

Booting up Kate, without changing the window size, is similar but it only seems to scale the text, and not the icons, which appear far too small.

After trawling through the forums, I presume this must be Wayland, but the confusing part is why it’s being used as the default at all, and why I can’t seem to switch back to the old Xorg (there is no button in the login screen like there used to be).

I also followed a guide which I thought would fix things but after rebooting nothing has changed.

What am I doing wrong? Have a made a fatal mistake buying an nvidia laptop - should I just return it and find something with AMD graphics?

Extra: I uninstalled, went into the UEFI, changed the graphics from “discrete” to “hybrid” mode, and reinstalled with proprietary drivers, and from this Manjaro seemed to decide to use Xorg. But everything was very slow when using an external monitor, presumably because it wasn’t using the GPU. I feel like I am stuck between two bad options here.

Conclusion: On the whole this is very frustrating, after many reinstalls I can’t figure out how to get this all to work. Manjaro has served me well on my desktop and I just wanted a powerful laptop to replace that with. I am happy to spend time troubleshooting but this feels ridiculous, from the get-go nothing is right. Is that just my bad for getting nvidia? I chose a Thinkpad because they come recommended as working well with Linux!

If I am repeating a tired complaint please link me to the forum post I didn’t manage to find.

In case this is useful

$ inxi --admin --verbosity=7 --filter --no-host --width
System:
  Kernel: 5.15.41-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=e4032116-8767-4105-80c8-404692e9ed2d rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20Y5CTO1WW
    v: ThinkPad X1 Extreme Gen 4i serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: LENOVO model: 20Y5CTO1WW serial: <superuser required> UEFI: LENOVO
    v: N40ET31W (1.13 ) date: 11/23/2021
Battery:
  ID-1: BAT0 charge: 90.0 Wh (99.9%) condition: 90.1/90.1 Wh (100.0%)
    volts: 17.7 min: 15.5 model: SMP 5B11B79217 type: Li-poly serial: <filter>
    status: not charging cycles: 2
Memory:
  RAM: total: 7.56 GiB used: 2.23 GiB (29.5%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x3E
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 846 high: 1042 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 818 2: 801 3: 800 4: 1042
    5: 801 6: 1001 7: 801 8: 820 9: 946 10: 801 11: 852 12: 851 13: 800
    14: 801 15: 789 16: 818 bogomips: 73744
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb erms est f16c flush_l1d fma fpu
    fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp hwp_notify
    hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single
    lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri msr mtrr
    nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good
    sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer
    tsc_known_freq umip vaes vme vpclmulqdq x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Lenovo
    driver: nvidia v: 510.73.05 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Ampere pcie: gen: 4 speed: 16 GT/s
    lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:25a0
    class-ID: 0300
  Device-2: Chicony Integrated RGB Camera type: USB driver: uvcvideo
    bus-ID: 3-8:3 chip-ID: 04f2:b71c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 191 s-size: 340x221mm (13.39x8.70")
    s-diag: 406mm (15.97")
  Monitor-1: DP-4 res: 2560x1600 hz: 60 dpi: 188
    size: 345x215mm (13.58x8.46") diag: 407mm (16") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3050 Ti Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.73.05 direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0401
  Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:2291 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.41-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp9s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 484.4 GiB used: 11.01 GiB (2.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVL2512HCJQ-00BL7 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: CL2QGXA7 temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Philips
    model: USB Flash Drive size: 7.46 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 11.01 GiB (2.4%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: e4032116-8767-4105-80c8-404692e9ed2d
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: AFC5-E65D
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/sda1 maj-min: 8:1 size: 3.53 GiB fs: iso9660
  ID-2: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: 2725-614A
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-6:2 info: Kingston Flash Drive type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 13fe:3d00 class-ID: 0806 serial: <filter>
  Device-2: 3-8:3 info: Chicony Integrated RGB Camera type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b71c class-ID: 0e02 serial: <filter>
  Device-3: 3-9:4 info: Synaptics type: <vendor specific> driver: N/A
    interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 06cb:00f9
    class-ID: ff00 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 43 C
  Fan Speeds (RPM): fan-1: 2584 fan-2: 2485
Info:
  Processes: 325 Uptime: 27m wakeups: 5317 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1193
  lib: 332 flatpak: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.16

You are on xorg, not Wayland.

1 Like

just a second to slow…
just to be shure:

echo $XDG_SESSION_TYPE

Thanks guys, you are right, that is X11/xorg. I was confused by the behaviour. In any case, I can’t get the scaling right! It says I’m at 100% global scale and can’t go down any further, but everything is either too big or too small! Is this just an nvidia issue?

Wayland might work better with scaling. Try it. I’ve been seeing people have good results with recent Nvidia drivers and Wayland.

It doesn’t work. I installed plasma-wayland-session, rebooted, chose Wayland, entered my password, goes to a black screen, resets back at password prompt 5 seconds later. A cursory look at journalctl reveals these entries with “wayland” at that time

Jun 09 01:17:11 dexter-thinkpad ksplashqml[818]: qt.qpa.wayland: Creating a fake screen in order for Qt not to crash
Jun 09 01:17:11 dexter-thinkpad ksplashqml[818]: The Wayland connection broke. Did the Wayland compositor die?
Jun 09 01:17:11 dexter-thinkpad ksplashqml[818]: qt.qpa.wayland: Creating a fake screen in order for Qt not to crash
Jun 09 01:17:11 dexter-thinkpad ksplashqml[818]: The Wayland connection broke. Did the Wayland compositor die?
Jun 09 01:17:11 dexter-thinkpad klauncher[825]: qt.qpa.wayland: Creating a fake screen in order for Qt not to crash
Jun 09 01:17:11 dexter-thinkpad klauncher[825]: The Wayland connection broke. Did the Wayland compositor die?

I have the same problem and there is a solution. With nvidia on my laptop, it seems that with kde there’s some DPI problems

add this option in your /etc/X11/xorg.conf on the “Device” or “Screen” section ;

Option “DPI” “96 x 96”

if you don’t have a xorg.conf, generate it via sudo nvidia-xconfig
Wayland doesn’t work for me with KDE-Nvidia, it’s not really ready yet, stick with x11 for now

2 Likes

Hey, thanks for the suggestion. I tried this on a brand new install but after rebooting nothing is different.

I’m really starting to think I should just return this machine and just get something with only intel integrated graphics… I only need to do light photo editing with GIMP and be able to run a couple 4K displays. I don’t want to be 10 years down the line and have nvidia’s proprietary drivers just drop support or something.

did you tried changing the dpi? go to system settings/fonts and force DPI to 96, click apply, if 96 doesnt work try different one

1 Like

You sir are my saviour!

After a couple of reboots I have settled on this combination:

  • System Settings → Display Configuration → Global scale: 150% (originally 100%)
  • System Settings → Fonts → Force font DPI: 144 (originally greyed out 96)

Everything looks great on both my laptop screen and external monitors. I’ll have to finish setting up my system proper with all applications to be sure, but things are looking very good right now.

As an aside, do you know if there’s a good way I can submit this feedback to the Manjaro team? I presume the issue is reproducible on at least every model of this laptop, and possibly more laptops with a similar configuration.

this is a kde issue, and its very likely a know issue to them, there are already posts with dpi/scalling issues… so you dont need to report anything…

Got it, no worries. Thanks again for your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.