Fresh install Gnome 21.07 no sound with Realtek ALC1220

I seem to be having issues with sound only with the onboard ALC1220. Sound coming from all other sources seem to be working fine. I am not sure what else to check or if its a kernel issue.

inxi -Fxzc0

           Device-2: NVIDIA TU102 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           Device-3: RODE Microphones RODE NT-USB type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3.1:21 
           Device-4: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-3.4.1:11 
           Device-5: Yamaha AG06/AG03 type: USB driver: snd-usb-audio bus-ID: 1-4.1:23 
           Device-6: Corsair ST100 Headset Output type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-7.1:20 
           Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.30 running: no 

Kernel: 5.10.42-1-MANJARO
DE: Gnome 3.38.4

Update 1:
So I found the issue it seems like my nvidia audio card was clashing with my on board sound.

/proc/asound/modules returned

0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_audio
3 snd_usb_audio
4 snd_usb_audio
5 snd_usb_audio

after editing/creating /etc/modprobe.d/modprobe.conf
added the line:

options snd_hda_intel enable=1,0

took a guess with which one to enable and disable

and that seems to have sorted the issue but removed the option to select output via HDMI…

1 Like

Welcome to the forum! :wave:

Tip: When pasting terminal output on Discourse forums, one can either…

  • Highlight it and use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):


  • Use HTML:


Please edit your post accordingly.

Partial data posted from inxi appears to have omitted audio card:1

But onboard audio is shown as detected in alsa-info

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

ALSA control for front headphone jack is shown as muted

Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [off]
  Front Right: Playback [off]

use this command to unmute it

amixer --card=0 sset Headphone unmute

Audio cards available in ALSA can be checked by name:

cat /proc/asound/cards

My problem actually started again after booting back into manjaro from windows today and sound stopped working.

Tried to do what you did no go seems like everything else sound wise is working expect for on board :frowning:

Fastboot etc. is disabled in windows and BIOS?

Yep fastboot is disabled