Fresh install fails, bootloader could not be installed

Hi, after breaking some packages by doing a system upgrade from the testing branch, I set out to reinstall Manjaro, but it fails when installing the bootloader. How can I fix this?

You may have some residual things left over, may be a good idea to reset the drive.
If there is nothing else on the drive, run Gparted from live USB, select your drive > delete all partitions > go to menu “Device” > and then “Create Partition Table”, select the GPT format and apply. Now you have a fresh disk ready to go.

Thanks DeLinuxCo, I was able to delete all partitions and create a new GPT partition table but I still get the bootloader installation error

I can confirm this problem on Qonos with the XFCE Minimal and Full install images.

The installer will throw that exact exception regardless of EFI partition size (32MB, 256MB, 512MB, 384MB) and root partition type (F2FS, ext4) on any disk with a GPT partition scheme. It even threw that exception when I instructed Calamares to wipe the disk clean and start afresh.

I would not be as annoyed by this if it weren’t for the fact that every ISO available for download right now is Qonos 21.2 rc1 - even the long-term support ISOs…

I found an older MATE full ISO and the same exception occurs with Pahvo 21.1.2.

Is the drive set to AHCI in the UEFI firmware?

Yes, my “SATA mode selection” is set to AHCI

A bit optimization: partitions info are stored in partition table. Creation of MBR/GPT partition table leads to lost previous information about partitions, cause partition table re-creation.

For me this was solved by looking at the output from efibootmgr and then deleting the second item

    ~  efibootmgr                                        INT ✘  4m 52s  
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0002
Boot0001* UEFI: Samsung Flash Drive 1100
Boot0002* UEFI: Samsung Flash Drive 1100, Partition 2

the doing

    ~  sudo efibootmgr -b 0002 -B                                    15 ✘ 
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001
Boot0001* UEFI: Samsung Flash Drive 1100
1 Like

I decided to retrace my steps:

  1. Boot from Manjaro Qonos 21.2-rc1 with copytoram kernel argument.
  2. dd if=/dev/zero of=/dev/sda to clean the drive
  3. Initialized GPT. Created 384 MiBy bootloader as EFI System partition; 472 GiBy root as Linux filesystem partition; remaining space partitioned as Microsoft basic data.
  4. Create filesystems: FAT-32 for the bootloader and “extra” space, F2FS for root.
  5. Confirmed that the “boot, esp” flags are set on the bootstrap partition with GParted. (Not actually necessary)
  6. Eject all media.
  7. Run Calamares (“Launch Installer”).
  8. Select “Manual Partitioning”: bootstrap parition mounts at “/boot/efi” (“boot” flag checked); root partition mounts to “/”; spare parition is left without a mount point.
  9. Continue installation as normal.
  10. Wait for the bootstrap installation to fail…
  11. …which it doesn’t despite executing the exact same steps that triggered the aforementioned exception.
  12. ???
  13. Click the “Restart now” checkbox and press “Done” button in Calamares.
  14. Wait for GRUB’s bootsplash… (which doesn’t show anything on screen at all).
  15. Stupefaction upon seeing the LightDM login screen.

This makes absolutely no sense at all.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.