Fresh install doesn't recognize password selected and verified at install time

I installed fresh copy (Downloaded from the manjaro site) and selected to logon automaticlly with the user password the same as the supervisor. (This is a client system that only I use)
When I boot the the harddrive system for the first time it wants a pw, and doesn’t like the pw I just created. Tried this twice, same result. Time to ask for help, if others have seen this.

Possibly language/keyboard settings?

Similar problems have also been discussed on the forum before, such as;

missing MODULES:

keyboard layout and HOOKS:

Did you install a fully encrypted system
and is the password requested to decrypt the system?
… to even begin to boot? …

In that case it is a keyboard layout problem - an english keyboard is assumed without further configuration.


The system boots, and displays the original background display with a window requesting pw.
When I key stuff at the login screen the characters match the keys I press. Yes this is a US English keyboard and that is what was choosen at install time. I don’t think this is a keyboard issue. Since I setup the install to automaticlly login, why do I get a login window at all !!!

The interesting thing I forgot to mention is, that the pw request window displays a userid of my full name rather then the userid name I entered at install information collection time. I’ve tried replacing the full name with the name I choose as the userid for the one and only id available to the install, no success.

I can’t lsmod the failing system, as I can NOT login the very first time I booted the system.

So: it is not an encrypted system and your problem lies elsewhere.

CTRL+ALT+F3 (for instance)
to get to see a TTY

log in there - or try to.

You know your user name - type it.
You know your password - type it.
You should be logged in - text only, but logged in

How is this going?

Well, my bad…
Re-nstalled, this time I realized that Manjaro installer didn’t remind or force me to enter a mount point, and so I set the main partition mount point to “/” and the efi partition mount point to /boot/efi and is working as expected.
Apparently a copy of the USB Manjaro is saved on the SSD as it, most likely has mount points defined and that Manjaro module was what was booting.
Thanks to all that contributed I appriciate the effort and thought put into you efforts.

I have no idea what that might mean.
The “explanation” for the eventual apparent success looks dodgy to me.

It may look dodgy but third time was a charm and the only thing I did differerntly in the install process was to define mount points for the EFI volume and the system volume.