Freezing When using Hybrid intel/nvidia and screensharing in KDE PLASMA

My hardware is a laptop Dell G3

CPU: Intel Core i5-9300H with UHD 630
Ram: 12GB DDR4
GPU: Nvidia 1050 3GB

KDE Plasma Version: 5.27.7
KDE Framework: 5.109.0
QT Version: 5.15.10
Kernel Version: ( I already tried 6.4.12 and 6.1 LTS)
Graphics X11 and Wayland

Nvidia Driver: 535.104.05

The problem:

First of all, when I install the OS and nvidia the system boot using compatbility mode with llvmpipe

After that I installed the optimus-manager and changed to hybrid mode, then I also installed switcheroo-control, that helps me to open the app just using a right click > properties > app > advanced settings > open with discrete gpu

In this case I tried with a native linux game called CS GO, I openned steam, the game openned using nvidia, everything seeming to be ok.

But when I start to make a screensharing and it doesnt matter where you are doing it, discord, jitsi, teams, google meet, whetever you are when you star to make a screensharing and turn back to the game the system freezes entirely, nothing works anymore, nor tty you can access.

The same problem happened with other games.

I also tried using archlinux and 2 things I’ve noted:

First: In archlinux I dont need to use optimus manager, and the system works without llvmpipe
Second: I just install switcheroo control and everything works withouth freezing.

Also another 2 friends of mine tried it and had the same problem

Does someone has any idea in how to solve that? what manjaro changed in the driver that only works with you have optimus installed and if not the system enter in compatbility mode using llvmpipe?