Freezing after /dev/sda1: clean

Few days ago there were a lot of updates for Manjaro and apps. I run them and now when i run again my laptop, it was displaying an error message that system could not start pkgfile database update.
After booting in text console mode using grub menu, i was able to update/reinstall pkgfile.

However even if this error message is not displayed anymore, my laptop is freezing after displaying the /dev/sda1: clean message
No other message is displayed. I’m able to boot in text console mode using grub menu and network is working. However system does not start the KDE plasma desktop.

So what could be the issue ?

what do you mean with grub? dont you mean tty - ctrl+alt+f2?
try rerun the update again from tty:
sudo pacman -Syu
post any errors

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )