Freesync, Tearfree, or Variable Refresh on Wayland

How on earth do you enable Freesync in the latest GNOME Manjaro?

For example, to change the value of freesync_video, which is presently “0”.

Creating a /etc/X11/xorg.conf.d/20-amdgpu.conf has not helped.

It’s the exact same problem posted a year ago by u/Pyotrech.

Can someone help me explaining how to activate it, please?

It wasn’t solved.

Thanks in advance.

Welcome to the forum! :wave:

I imagine this will help you: Variable refresh rate - ArchWiki

If you still need assistance, please review the following and share the pertinent information so others will be able to help: [HowTo] Request support

I’ve tried that. To answer

First the Archwiki refers to /etc/X11/xorg.conf.d/20-amdgpu.conf. My instance is Wayland and this did not work.
Second, xrandr --props does not output
vrr_capable: 1
range: (0, 1)
it outputs
Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 530mm x 300mm
RANDR Emulation: 1
non-desktop: 0
supported: 0, 1
with available resolutions

systool -vm amdgpu does give an output, and it’s in the parameters for Module = “amdgpu”

freesync_video = “0”

Creating an /etc/X11/xorg.conf.d/20-amdgpu.conf file did not enable freesync or change the value outputted by systool. Any other solutions?

Switch to X (on login screen).

Don’t use Wayland if you try to configure X11 and expect your X11 configuration to work… That sounds obvious, no?

Variable refresh rate (VRR) has already been enabled.

See the limitation in Arch Wiki:

GNOME Wayland is not yet supported [15]

AFAIK, freesync works fine on KDE Wayland with Amdgpu + monitor with official freesync, KDE Xorg does not, but it uses “V-Sync”.


If you want freesync_video = "1", then add a kernel parameter amdgpu.freesync_video:

For GRUB user:

  1. Edit /etc/default/grub.

  2. GRUB_CMDLINE_LINUX_DEFAULT= adds amdgpu.freesync_video=1

  3. Run $ sudo update-grub and reboot.

If you use Wayland, you do not need to create the config /etc/X11/xorg.conf.d/20-amdgpu.conf for X11 only.

Do not use xrandr --props for X11 only. Try to install wlr-randr or gnome-randr-rust from AUR

1 Like


It did occur to me that going into the /etc/X11 folder to configure Wayland was a stretch, but I thought maybe a Wayland config folder I didn’t know about might’ve pointed to it :wink: Okay Okay…
Thank you for the gnome-randr-rust program, I’d never heard of it. It’s in the early stages, with only three subcommands: help, modify and query, but it works!

Also, most of all, thank you for

GRUB_CMDLINE_LINUX_DEFAULT= adds amdgpu.freesync_video=1

That solved my problem.

Shame there isn’t another option than to modify the grub file. There should be a .conf file you can fiddle with instead.

There is. Instead of modifying the kernel parameters in /etc/default/grub, you can add a configuration file to /etc/modprobe.d/; i.e, amd-freesync.conf with the following contents:

options amdgpu.freesync_video=1

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.