Fractal/Matrix work around for MMS on PinePhone

First post on the forum and I’m new to Linux, but crash-coursing so there will probably be a lot of basic questions. I’ll try to give as much background as I can.

I purchased a Pine Phone Beta edition with convergence package. I settled on Manjaro Arm Phosh beta 34 for the distro. And I’m on the Metro PCS ( T-mobile network) in the U.S. So of course that means I have call, SMS, data, but no MMS.

I read through the article on how to set up Fractal through terminal (wiki pine64 org wiki PinePhone MMS with Matrix), but I’lll be real-- I was totally lost. I’ve run a few commands through terminal (like looking for clogged sms and clearing them), but without step-by-step guides or a DIY video I was lost with all that. So given the quick pace of distro development I opened Fractal and tried to set it up from there-- hoping for the best.

Fractal prompted me to create an account and directed me to Element. I did that. Element asked me to download Element apk from fDroid. I think I did that, but I don’t see it on my phone. So then I went back to Fractal and tried to log in. When Fractal prompted for my “provider,” I listed my identity server ( which according to Element doesn’t support phone numbers ). I entered my login info for Element, but I keep getting " Can’t Log in " in Fractal. I’ve tried both Username and and of course Password. I even tried the Manjaro username and password.

What am I doing wrong? Do I need to go back to Terminal and type a bunch of commands?

Thanks in advance.

The PinePhone does not support Android APKs.

I cannot answer the questions because I am not familiar with Fractal, but I doubt Fractal is the answer to your MMS issues. If people are sending you MMS to your phone number, you will not be able to receive them and clear the SMS/MMS queue with a Matrix client like Fractal, because those are completely different protocols.

EDIT: I see your post on the Pine64 forum now and the link there:
So that sets up an MMS to Matrix bridge locally on the phone. That can work, but only if you can receive MMS on the phone to begin with, in which case they should just work without all that complex set up. (Both Chatty and Spacebar support MMS these days.) If you have issues with, e.g., the APN setup, then the bridge will not help you either.

Just to provide more data on my situation.

My phone will get clogged with messages that don’t show up on Chatty. Then it stops receiving SMS.

I run these commands in Terminal ( called Console on my phone):
$ mmcli -m any --messaging-list-sms

the phone responds with something like this:

Found 10 SMS messages:
/org/freedesktop/ModemManager1/SMS/0 (received)

But it will say that 10 times for 10 messages with the last digit counting up.

Then I run:

$ mmcli -m any --messaging-delete-sms=0

and repeat that, changing the last digit to match all the messages the phone listed. After that all my SMS that hadn’t come through before show up on Chatty-- even showing the correct time when the SMS was sent. I think I even raised my reception from 2G to 4G. I presume those stuck messages are the MMS. And that makes me think the phone is receiving them, but Chatty can’t process them. Obviously I could be wrong. I got the Terminal commands from this article ( wiki pine64 org wiki PinePhone_FAQ#The phone does not receive SMS )

Thanks to help from others on the Pine wiki boards I was able to use Chatty and no longer need to mess with Matrix. I’m running Manjaro Phosh beta 34 on the PInephone (not pro) on the Metro PCS network. Originally, when I tried to enter the MMSC Carrier Settings (Chatty>Preferences>SMS and MMS settings> MMSC Carrier Settings) in Chatty the section was dark. It wouldn’t let me enter it until I upgraded the firmware. So now I can just use Chatty.

Here’s the solution.

  1. Download a Firmware button/app
  2. Upgrade the firmware ( it will say downgrade ) to version 0.7.2
  3. get the correct ADSP firmware (for Tmobile)
  4. Reboot/Reflash the phone
  5. Enter the correct MMSC Carrier Settings (Chatty>Preferences>SMS and MMS settings> MMSC Carrier Settings). Link for Metro PCS : Metro by T-Mobile APN Settings

Big Thanks to mikehenson for the step-by-step videos. Note: you only need the first 6 minutes or so of the fist video to get the Firmware button. The second 8 minute video covers the ADSP.
Videos for reference:
PinePhone OR PinePhone Pro (4of5) - Phosh - Setup - Biktorgj - osmin - brave…99&index=7
00:00 Intro
00:10 Log into phone
00:28 install gnome-firmware
01:00 run gnome-firmware
01:00 run gnome-firmware
03:20 Fail, Run again
04:20 Downgrade again
05:55 Biktorgj is loaded
06:30 verify the ADSP version

Loading the ASDP firmware…99&index=2
mikehenson’s phone in videos
Device: PinePhone 32Gig (Used for building packages)
Device: PinePhonePro (Daily driver)
OS: DanctNIX Arch with Phosh
Carrier: USA - Patriot Mobile (T-Mobile SIM)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.