FPS Stuttering On Steam

I recently just reinstall Manjaro KDE and when I installed celluloid it didn’t show up plus my games just started stuttering.

Please Help.

Hello Snowman,

first you should read the following, to make it the others possible to help you with your problem.

At all there are not enough information to help you especially with your games problem. What games? Via steam or lutris or something else? Why did reinstall manjaro and do you use you old home-directory?

To get the celluloid-problem closer start celluloid from terminal. Then you can probably see any output which can give you a hint to the problem. :grinning:

Ok thanks!

Ok the games I have tried playing are Gang Beast, and Cuphead, they both seem to stutter on steam but not on lutris. BTW I fixed Celluloid not showing up.

Welcome to the forum! :wave:

What does that have to do with…

One issue per topic, please. This will be about your gaming issue.

Please see: How to Post

Please read and follow @kisun’s instructions above.

You mentioned you “reinstalled Manjaro”… and this is also your first post… so I’m guessing that you perhaps freshly installed Manjaro; maybe replacing Windows? If so, then you might be in my shoes about 4+ months ago… Welcome aboard! :wave:

My GNU/Linux gaming is strictly under Steam/Proton at the moment, and I’ll share some settings/tips specifically for Steam… but before I do that, two questions:

  1. Do you have an AMD GPU/APU or and nVidia GPU?
  2. If you have an nvidia GPU, are you using the Proprietary driver or the OpenSource driver?

My understanding is that the opensource driver isn’t robust enough to offer excellent game play on nVidia cards… I’m an AMD GPU user, so there really isn’t much more explanation I can offer in this case.

Here are my Steam tips…

  1. Read How should I opt into the steam Client Beta? - #4 by Daniel-I and ensure you have both opted into the “Steam Beta” and have enabled “Steam Play”
  2. Visit https://www.protondb.com/ and lookup your game(s). Sometimes people will post adjustments they had to make to get things working… specific Proton version, launch commands, etc
  3. Now that you have enabled “Steam Play”, you’ll have the option to select a specific proton version per game in it’s “Steam properties” if you found that’s what worked for others @ protondb.com
  4. Sometimes (I think CIV 5 is one example) even a game that says it has native Linux Support in Steam will run better if you force it to use “Steam Play”/Proton… usually people report this @ protondb.com if that is the case

Hopefully something I’ve posted here helps you… or teases some extra details out that leads to your solution.

P.S. I think opting into the Steam Beta also gets you access to the latest “Proton Experimental” builds. I’ve seen Proton Experimental get updated up to a few times per week, so I imagine there are lots of tweaks fixes that a non-Beta participant would miss out on. I like to check https://steamdb.info/app/1493710/patchnotes/ for the “Proton Experimental” changes.