Forza in Steam freezes/crashes, used to be stable

Hi, I’m trying to get Forza Horizon 5 to be stable again. I say “again” because it used to be fairly stable. I could play for hours and it would occasionally crash, but I felt playing while streaming for 4 or 5 hours before a crash was acceptable.

I had some issues recently with the big JULY 2023 Manjaro update but those issues have all been resolved, thanks to this forum.

I have a LOT of info to share but let me know if you need more…

Basic System Info:
OS: Manjaro Linux x86_64
Kernel: 5.15.120-1-MANJARO
DE: Xfce v: 4.18.1 tk: Gtk v: 3.24.36
GPU: NVIDIA GeForce RTX 3070 driver: nvidia v: 535.54.03

More Detail:

  Kernel: 5.15.120-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=7f43684f-af68-4b29-a9b3-e5b81a7ddf9d rw quiet intel_iommu=on
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: 1: GDM v: 44.1 note: stopped 2: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG MAXIMUS XI HERO (WI-FI) v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 0602
    date: 10/19/2018
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  System RAM: total: 64 GiB note: est. available: 62.71 GiB
    used: 4.49 GiB (7.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i9-9900KF bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xC (12) microcode: 0xF2
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 16 MiB
    desc: 1x16 MiB
  Speed (MHz): avg: 1403 high: 3200 min/max: 800/5000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 826 2: 1429 3: 1200
    4: 1200 5: 1554 6: 1699 7: 802 8: 800 9: 800 10: 800 11: 2450 12: 3200
    13: 802 14: 1064 15: 2630 16: 1200 bogomips: 115232
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate] vendor:
    driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2488
    class-ID: 0300
  Device-2: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-2.2:3
    chip-ID: 046d:08e5 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: xfwm v: 4.18.0 driver: X: loaded: nvidia gpu: nvidia
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 96 s-size: 1355x381mm (53.35x15.00")
    s-diag: 1408mm (55.42")
  Monitor-1: DP-2 pos: primary,left res: 2560x1440 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-2: DP-4 pos: right res: 2560x1440 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce RTX
    3070/PCIe/SSE2 direct-render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GA104 High Definition Audio vendor:
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228b
    class-ID: 0403
  Device-3: Logitech Yeti X driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3
    chip-ID: 046d:0aaf class-ID: 0300 serial: <filter>
  Device-4: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-2.2:3
    chip-ID: 046d:08e5 class-ID: 0102 serial: <filter>
  API: ALSA v: k5.15.120-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.74 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol

PREVIOUSLY (before the recent system updates, Proton update, and Nvidia driver update):

  • Proton 8.0-2
  • GPU Driver: NVIDIA 530.41.03
  • LAUNCH OPTIONS: gamemoderun %command%
  • GAME OPTIONS: 1920x1080, Vsync=OFF, 60fps, Graphics=ULTRA
  • RESULT: The game loaded without any warning dialogs and ran fine. I could play for hours with only a crash or freeze every now and then. Many times I was using OBS to live stream and had several browser tabs open.


  • Proton 8.0-3
  • GPU Driver: NVIDIA 535.54.03
  • GAME OPTIONS: 1920x1080, Vsync=OFF, 60fps, Graphics=CUSTOM, turned some options down from Ultra to High
  • RESULTS: Now I get when a warning dialog when I launch the game that says, “We have detected the following hardware issues: Unable to detect graphics driver version … bla bla bla” so I just hit IGNORE. But WHY? I didn’t have this before!
  • Then, once I get to the menu screen and click CONTINUE, the game takes 3 MINUTES to start (it keeps cycling through info screens showing your different achievements). Previously the game loaded in about 20 seconds.
  • Once the game FINALLY loads, I get a warning about a Screen Reader, but then I can finally play the game.
  • I still get a clean 60fps but last night it crashed after 15 minutes while I was streaming. Sometimes it also runs for hours before freezing. It doesn’t seem to matter if I’m streaming or not. It crashes randomly with no other apps running. Also, after maybe an hour of playing, the half-second lags start to get pretty bad. Could this just be a BAD NVIDIA driver???


  • I recently had issues with one of my monitors going black then coming back on. I fixed this by lowering my monitor refresh rates from 144hz to 120hz. I’ve been running 144hz for over a year with no issue. I did a Timeshift back to July 4 and the monitors work fine at 144hz. I actually did this several times to eliminate hardware issues and it was always the same: monitors work fine before the updates, monitors have to run at 120hz after the updates. I’m gonna GUESS this is a NVIDIA driver issue?
  • I turned on PROTON LOGS and I looked at the log from my crash last night. I saw a lot of:
gamemodeauto: dlopen failed - cannot open shared object file: No such file or directory
gamemodeauto: dlopen failed - cannot open shared object file: No such file or directory
gamemodeauto: dlopen failed - cannot open shared object file: No such file or directory
gamemodeauto: dlopen failed - cannot open shared object file: No such file or directory
gamemodeauto: dlopen failed - cannot open shared object file: No such file or directory
gamemodeauto: dlopen failed - cannot open shared object file: No such file or directory
  • So, I reinstalled gamemode and it seemed to install fine. But I ran Forza just now for 10 minutes and I looked at the new log and those lines are still there.
  • In a Forza forum someone suggested rolling back to the previous NVIDIA driver to see how that goes. I haven’t done that yet because I need to look up how to do it.
  • I’ve tried the latest TWO versions of GE-PROTON and its worse- the game crashes or freezes within 10 minutes. I’ve used GE-PROTON in the past with great success for other games.
  • I’ve tried Proton EXPERIMENTAL and it also crashes within 15 minutes.
  • I’ve tried various combinations of LAUNCH OPTIONS without any improvement, although I don’t know what all the different options do. I just tried various options other people said were successful.

I’m happy to provide any other info or to run tests, upload logs, etc.


Did you try to delete the shader cache? A new driver always needs fresh compiled shaders. Most common issue on Windows also, when you update drivers.


I will try that now and report back.

The new warning dialog “We have detected the following hardware issues: Unable to detect graphics driver version …” and the 3 minute load time are pretty weird though, no??

Must be the caused by the update of proton or the game itself. Probably it hides the nvidia card by default now? PROTON_HIDE_NVIDIA_GPU=1
See: GitHub - ValveSoftware/Proton: Compatibility tool for Steam Play based on Wine and additional components

I know that steam tinkers’ proton to work with specific games.

Okay, I went into the shadercache folder and there were subfolders in there. Do those folder names match the game app ID? Because there was no 1551360 folder in there. There were folders for my other games though.

When I ran the game just now, it did NOT do the usual “Processing Vulkan Shaders” wait box.


Is the game on a different steam library? Look there.

Okay I found the right shadercache folder on the drive where I installed the game. The 1551360 folder WAS there and I deleted it. Still no “Processing Vulkan Shaders” dialog. Could that be what its doing for 3 minutes?

BUT the games loads, and I get to the main menu. Its only AFTER I click CONTINUE, that it takes 3 minutes to load before I can play.

It process with precompiled (downloaded) Shader Cache.

No idea. I guess Steam devs can answer your question better. But yes, since games compile shaders on start time, it can take time.

Thanks for your replies so far! I just installed mangohud and I’m going to see if that shows anything interesting. I’m also gonna try some different Launch Options from the GitHub page you linked.

Finally, I’ll try rolling back the NVIDIA driver (once I learn how to do that, lol)

UPDATE: I installed and configured mangohud. It shows a bunch of good info, but nothing looks out of the ordinary…

Can you test this


Just the opposite, actually. PROTON_HIDE_NVIDIA_GPU=0 has been default for quite some time now.

Just tried it. I still get the “Unable to detect graphics driver version…”, I click Ignore, then the game crashes immediately.

So, I just finished reading Configure Graphics Cards - Manjaro but I didn’t see how to revert the NVIDIA driver back to the previous v530 from my current v535. Can someone tell me how to do that or share a link? Thx

Welp, now the game doesn’t load at all. I tried switching to PROTON Experimental and the game DID load but it crashed. I switched back to PROTON 8.0-3 and now Steam just says “Launching” but nothing happens.

I tried deleting the shadercache folder but that doesn’t seem to help.

Other Steam games DO load and play

I just used Timeshift to restore my system to yesterday, then in Steam, I verified all of the Forza game files. Now the game starts but I got a black screen after hitting CONTINUE on the main menu. I fixed that with ALT+Enter which goes from fullscreen to windowed mode, then I had to log into my Xbox account again.

I did my usual Twitch stream tonight and Forza crashed twice. Both times it caused OBS to crash as well. Now, I’m working on reducing the graphics settings even further to see if I can get some stability. When the game first runs and does its own “Optimizing for your PC” thing, its own test RESULTS says I should be able to run the game with “Extreme” graphics settings.

Like magic, the 2023-07-27 Stable Update came and I installed it this morning.

Along with a bunch of stuff, the NVIDIA driver was updated from 535.54.03 to 535.86.05

Now Forza seems MUCH MORE STABLE:

  • When I started the game, I got the normal “Processing Vulkan Shaders” dialog that I had not seen before
  • When Forza first starts, I STILL get the “Unable to detect graphics driver version…” dialog box but I just click IGNORE
  • Once at the main menu, I hit CONTINUE and the game NO LONGER takes 3 Minutes to start but starts in about 20 seconds.
  • I tested it quite a bit this evening and it never crashed. After about an hour of playing, the short lags started happening more often, but quitting the game and restarting it fixed that.

UPDATE 2023-07-28:
The game STILL crashes but I can usually play for at least an hour. Crashes seems completely random. It crashed after 1hr 10min, then after only 16min, then after 2hr 5min.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.