Forza Horizon 5 freezing constantly (unplayable)

Hello there!

I would love to count with your help if possible.

I am trying to run Forza Horizon 5 on my Manjaro KDE (through Valve’s Proton) but the game is pratically unplayable. I was not able even to finish the introductory part (on which that guy is giving gameplay instructions).

That’s because the game freezes completely after just a few seconds running, and I have to force close it.

I have played around with several options, enabling and disabling things, reducing the overall quality, etc, etc, without success.

My machine has 16GB RAM, i7 7700 processor. I can perfectly run other games, as the other one I am currently playing (No Man’s Sky), without any issues. Just Forza Horizon 5 is unplayable.

It freezes completely while the sound still playing. I looked at ProtonDB and saw that many people are getting to play it on Linux.

Well, thanks in advance for any help.

CPU: quad core Intel Core i7-7700HQ (-MT MCP-) speed/min/max: 889/800/3800 MHz
Kernel: 5.15.78-1-MANJARO x86_64 Up: 3h 41m Mem: 3522.8/15882.6 MiB (22.2%)
Storage: 2.27 TiB (30.0% used) Procs: 264 Shell: Zsh inxi: 3.3.23

P.S.: I noticed that totally disabling the firewall (I have GUFW) results in more time of “gameplay” (I can play a bit more before the game freezes totally).

So you play with your Intel iGPU? Ridiculous… I guess if you have hybrid gpu (intel+nvdia)?

Steam Startup Option:

prime-run %command%

That should use the nvidia gpu.

No, I play using the Nvidia card.

Just so I can run No Man’s Sky without issues, for example.

Again: Are you sure that games use the nvidia gpu instead of the intel one?

  1. You did not even mention your nvidia card in your first post.
  2. Do you know or assume that you play with nivida card?

However… the freeze problem can also happen when you reach the end of the RAM and have no swap device or your VRAM exceeded.


Sorry for that! I forgot to mention that I have a hybrid laptop, which has a Nvidia GTX 1060 card.

I assume that I am playing with the Nvidia card. Well, I think so, also because No Man’s Sky, for example, is running perfectly without any issue.

I suppose that this is possible just because I am running it using the Nvidia. Maybe I am wrong, I don’t know, but I guess that that game would not be playable in other way.

So, I have 16GB of RAM (DDR4) and a swap of 32GB.

This is very strange. Because Forza Horizon 5, in the few minutes I get to play it, is perfectly playable. I mean, in that few minutes (2 or 3 minutes), everything goes smoothly, without issues.

This until everything froozes up, so I have to do ALT+TAB, access the Steam client and click in the button to finish the game.

P.S.: that prime-run %command% launch option did not help, unfortunately.

You have tested the Tipps from here ?

Thanks for pointing me to that! I’ll try that tonight! :slight_smile:

Well, unfortunately nothing solved the issue. :frowning:

The game remains unplayable.

What I found

One Tipp : Disable half rate shading

Thank you. I’ll take a look.

Well, nothing has solved the issue, unfortunately. :frowning:

I’m on PC (running Manjaro KDE), so I think that half rate shading is something related to Steam Deck.

I already tried several things, including several Proton versions, etc.

Maybe I need to forget this game for now.