Forth-mode in Emacs GUI read-only; package cl is deprecated

I successfully installed the GUI version of Emacs on my freshly-installed Manjaro KDE system on my laptop. When I tried to install forth-mode, it appeared to succeed, but I was immediately warned with “Package cl is deprecated”, and the file was read-only, so it wouldn’t let my edit it. By contrast, I also installed org-mode, and it’s working exactly as it should.

I tried creating a new file and then running forth in it; I could type in the this one, but when I try to run forth, I’m prompted for a forth expression. But even when I put in 1 2 + in the bottom line where command input/output is displayed (I don’t know its proper name) simply said “Searching for program: No such file or directory”. When I ran C-c : , the same occurred, “Searching for program: No such file or directory”.

Here are some resources I’ve already looked at in trying to troubleshoot the problem:

Other info which could be of use:

It appears the version of Emacs I’m running uses something called cl instead of cl-lib. I installed Emacs from the Manjaro Software centre, and I’d also like to note that for the two days I’ve been running Manjaro on my laptop, I keep being told my system is up to date, which I find dubious at best.

FYI: I’m trying to learn forth, and I have a very limited understanding of Emacs. I am fairly comfortable with org-mode already, and I can get around with minimal help, but otherwise I’m a complete noob.

UPDATE: I turned on my laptop again just now, and I did in fact receive a prompt to update, which I did successfully.