Force Manjaro to install in BIOS/MBR mode

My laptop Fujitsu Lifebook E782 refuses to boot USB iso’s in MBR mode, even though Windows 7 and other Linux OS’s are installed in MBR mode on this laptop. There are no settings in BIOS to get around this problem. I was always able to get around this problem by burning the iso using Rufus in Windows, and then renaming the EFI folder, which forced the laptop to boot in MBR mode. This is how I originally installed Manjaro a few years ago.
Now following the big update to Plasma 5.21.4 the system was wrecked, so I finally decided to re-install Manjaro. This time the trick with renaming the EFI folder would not work, so there was no way for me to install Manjaro.
I finally found a solution, and maybe it can help others with older hardware. (I’ve seen posts related to this on this site, but did not find a solution that worked for me.)
This is what worked for me:

  • Download Super Grub2 Disk, not the hybrid version but the “Old BIOS (non UEFI)” version. Burn this to a USB disk.

  • Burn the Manjaro iso using Rufus in iso mode (so that the folders will be editable).

  • On the Manjaro-USB stick, rename the EFI folder to something else, such as EFI_old.

  • Put both USB sticks into the computer, and boot from Super Grub2 Disk.

  • There should be a list of bootable systems under “Boot manually…”. Trial and error will help to find the Manjaro installer.

  • Install as usual, and ignore the warning to create UEFI partitions.

That will not work

If you really want to use BIOS mode you should disable EFI in the firmware.

I don’t fully understand why you have this problem. I use BIOS/MBR ISO’s on an USB stick (not only from Manjaro) since years without any problems. When I boot my Fujitsu computer via firmware I can simply select there the non-UEFI entry and the computer boots in BIOS mode, Manjaro ISO’s are of hybrid design, i.e. suitable to boot either in UEFI or in BIOS mode. I don’t need to disable UEFI mode on my computer. I think you should double-check ALL your firmware options carefully, these are different from computer to computer and therefore we cannot help you much.

you should use ventoy for USB iso manjaro

I was not looking for help in this post, but offering help to others who may have the same problem (whom I could see by searching this forum). The steps that I outlined did indeed work for me today.

I had been having this problem with only this laptop for some years, until I discovered the trick of renaming the EFI folder. It worked for OpenSuse, Kubuntu, Debian, and until now with Manjaro. It did not work with MX a couple of years ago. Because of the problem with MX I went up and down the BIOS settings, in and out, plus updating BIOS, to no avail.
It worked with Manjaro today only because I tried the Super Grub2 Disk BIOS version.

I haven’t heard of Ventoy before, but I’ll check it out.

I use manjaro in EFI and MSDOS without problems for years and the only thing I have to do is press F11 or F12 depending on the shortcut

I can’t put my terminal’s command output in preformatted text here

Sorry my bad english

T+ = So long