Force KDE to adhere to the IBM CUA: Ctrl+Esc

So I’m an old curmudgeon, and have been using various OSes over my lifetime and recently switched over to KDE (6 months ago) and so far it’s allowed me to customise everything the way I want it to be, except 1 minor thing:

I want:

  • Ctrl+Esc to bring up the menu instead of the Meta key

As defined in the IBM CUA which even Gnome on my previous Linux distro adhered to… ([Cough] Ubuntu [Cough]).

I’ve Googled DDGed around a bit but cannot seem to locate how to do this and it really annoys me!

Anyone around here that knows how to perform this feat?


@Fabby, if you don’t know then there is no saving civilisation.

1 Like

If you know tell him.

Sorry but I don’t know the answer. I’m guessing you have made all your other shortcut settings in - system settings - shortcuts?

@toast I’m going to register on the KDE forum and ask the same question there as all of the KDE fanatics here on the forum are awake by now and have read this question already.

And @seacrow and me are one of the bunch answering questions here on the forum, not posting questions and that’s why he said what he said and why I only responded with a :stuck_out_tongue_winking_eye: and a :heart: below his post.

:grin: :innocent:

P.S. :+1: Welcome to Manjaro! :+1:

1 Like

Ah - I see. I wondered why he sounded unhelpful.

Can’t you find the actions you are after in the plasma part of the shortcuts section.

I can’t, that’s why I’m asking…


To have Ctrl+Esc open the application launcher:

  • Right click the start button
  • Click Configure application launcher
  • Click Keyboard shortcuts
  • Click on the current setting button that shows alt + f1
  • Press the Ctrl+Esc buttons on your keyboard
  • It will complain that it’s assigned to some other function so you will have to confirm your choice.
  • Click OK

To disable the meta key from opening the application launcher:

  • execute:

    nano ~/.config/kwinrc
  • copy paste the following at the end of the file:

  • Save, log off, log on again.

1 Like

I see your system menu image. I would have called that the right click menu, and my keyboard has a button that does that without any configuration. It’s just to the right of the right hand side ctrl button.

According to a post on reddit you can, assuming you don’t have the right click menu key on your keyboard, map another key to do the same thing:

Apparently I cannot post links either…

Ok, to find the post use these as your search terms in startpage:

kde keyboard shortcut right click menu

It was the top result for me.

Only way I could post your edit was to removed the image from it. I’m guessing I have not posted enough on the forum to be able to post links and images??

And is there an easier way to create the boxes than typing < kbd > < /kbd > every time (spaces added to block auto formatting).

I believe you will be able to do so once you become a Member (Trust Level (TL) 2). However, I believe the requirements for becoming a member are undocumented.

1 Like

Nope, here they are as that’s the software we use to run this forum…


Those are the default Discourse requirements. I understand they have been customized on this installation, and that would explain why I am still Basic, even though I believe I have met all the default requirements.

1 Like

Thanks for the replies. I’m not a heavy forum user anyway, but when I was trying to show something it made it more difficult.

I am a known user (to the previous forum), but not by username. System didn’t recognize my email address though - which makes sense as I read that everything got nuked.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.