Fonts blurred on the start menu

I am on the KDE plasma version of Manjaro 20.0.3. The text/fonts below the icons in the start menu panel sometimes go blur and the text is not readable. It works when I close out the menu a few times and reopen it or change the desktop theme. Is this a bug or something I messed up.

Any help would be much appreciated.


Hello and welcome.

If by changing the theme solves the issue, then make sure the actual theme you want to use is updated.
Try to clean the content of ~/.cache/ folder in your user home, reboot and see if the issue persists.

Are you running compton / picom?

If you kill it, does the blurring vanish?

Thanks for the tip. I’ll give it a try

Not sure if it already comes by default, but I have not installed it manually.

@bogdancovaciu, I tried with different themes. Issue is intermittent but goes away if If I change some UI settings like changing the theme or fonts or icons etc. Comes back eventually again.

I am not allowed to share images or links yet so not able to show you guys.

Provide from terminal
inxi -Fxza --no-host

Use the default settings and themes, after you clean the cache and do a couple of reboots. If the issue is not present, then might be related to the themes you set and are not provided by us.
If the compositor crashes, then that might be also a hint. Set it like this:


Thanks for your response. I have been using the default theme and have tried using other themes as well. The compositor settings we Set to OpenGL 2.0 first but I have matched the settings you have provided with still no luck after reboot. Here is the sys info from the terminal output you had asked:

System:    Kernel: 5.7.17-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
       parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=976990cc-1581-4f88-91b8-0a71239e7240 rw quiet apparmor=1 
       security=apparmor resume=UUID=2e389762-7a3e-4832-97a7-86c5065fa7ca udev.log_priority=3 
       Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7C02 v: 1.0 serial: <filter> 
       Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0 serial: <filter> UEFI [Legacy]: 
American Megatrends 
       v: 3.60 date: 04/22/2020 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> charge: 55% (should be ignored) 
       rechargeable: yes status: Discharging 
       Device-2: hidpp_battery_1 model: Logitech Wireless Mouse serial: <filter> charge: 55% (should be ignored) 
       rechargeable: yes status: Discharging 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
       stepping: N/A microcode: 8701021 L2 cache: 3072 KiB 
       flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 91230 
       Speed: 2199 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 2282 2: 2006 3: 2055 4: 2059 5: 2027 
       6: 3590 7: 2057 8: 2057 9: 2470 10: 2029 11: 2025 12: 3599 
       Vulnerabilities: Type: itlb_multihit status: Not affected 
       Type: l1tf status: Not affected 
       Type: mds status: Not affected 
       Type: meltdown status: Not affected 
       Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
       Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
       Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
       Type: srbds status: Not affected 
       Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Micro-Star MSI driver: nvidia v: 450.66 
       alternate: nouveau,nvidia_drm bus ID: 26:00.0 chip ID: 10de:2182 
       Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: nvidia display ID: :0 screens: 1 
       Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.7x13.5") s-diag: 693mm (27.3") 
       Monitor-1: DP-2 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
       OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 direct render: Yes 
Audio:     Device-1: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 26:00.1 
       chip ID: 10de:1aeb 
       Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
       v: kernel bus ID: 28:00.4 chip ID: 1022:1487 
       Sound Server: ALSA v: k5.7.17-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
       port: f000 bus ID: 22:00.0 chip ID: 10ec:8168 
       IF: enp34s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
       IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.66 TiB used: 25.24 GiB (1.5%) 
       SMART Message: Unable to run smartctl. Root privileges required. 
       ID-1: /dev/sda vendor: Western Digital model: WD3200AAJS-00L7A0 size: 298.09 GiB block size: physical: 512 B 
       logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 3E01 scheme: MBR 
       ID-2: /dev/sdb vendor: Seagate model: ST31000528AS size: 931.51 GiB block size: physical: 512 B logical: 512 B 
       speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC38 scheme: MBR 
       ID-3: /dev/sdc vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB block size: physical: 4096 B 
       logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: KC44 scheme: MBR 
Partition: ID-1: / raw size: 92.00 GiB size: 90.05 GiB (97.89%) used: 25.24 GiB (28.0%) fs: ext4 dev: /dev/sda4 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
       ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 45.1 C mobo: N/A gpu: nvidia temp: 34 C 
       Fan Speeds (RPM): N/A gpu: nvidia fan: 43% 
Info:      Processes: 278 Uptime: 6m Memory: 15.65 GiB used: 1.27 GiB (8.1%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
       Packages: pacman: 1268 lib: 349 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

Please also provide:
mhwd -li
cat /etc/modprobe.d/mhwd-gpu.conf
cat /etc/modules-load.d/mhwd-gpu.conf
cat /etc/X11/mhwd.d/nvidia.conf

mhwd -li

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-450xx            2019.10.25               false            PCI
       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

cat /etc/modprobe.d/mhwd-gpu.conf

## Generated by mhwd - Manjaro Hardware Detection

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

cat /etc/modules-load.d/mhwd-gpu.conf

## Generated by mhwd - Manjaro Hardware Detection


cat /etc/X11/mhwd.d/nvidia.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 450.57

Section "ServerLayout"
Identifier     "Layout0"
Screen      0  "Screen0"
InputDevice    "Keyboard0" "CoreKeyboard"
InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

Section "Monitor"
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Unknown"
Option         "DPMS"

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
    Option "NoLogo" "1"

Section "Screen"
Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
SubSection     "Display"
    Depth       24

Section "Extensions"
Option         "COMPOSITE" "Enable"

Section "InputClass"
Identifier          "Keyboard Defaults"
MatchIsKeyboard        "yes"
Option              "XkbOptions" "terminate:ctrl_alt_bksp"

i suggest to remove the video-linux driver, and then try this

and this

IMHO it should help with the font issue too.

@bogdancovaciu - Thanks for the detailed explanation and sorry for the delay in response. After removing the video-linux driver, I am not seeing the issue from the past couple of days.
It may have done the trick. But have not made the other plasma config changes. Will try it out if the issue re-appears and will keep monitoring. But for now it looks good to close.

I appreciate your help and assistance regarding the issue.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.