Folders in Veracrypt Container Mounted as Read-only File System

I have previously been able to access with full permissions on folders within my Veracrypt container in my previous Manjaro installation. That installation became corrupted with many failed attempts to repair it and so I reinstalled Manjaro fresh again. Now, with the new installation installed with Veracrypt, the latter is only mounted as Read-only File System. I didn’t think there was an option to choose how a Veracrypt container could be mounted either.

I tried to change permissions with the following commands but it is still not working.

sudo chown -R danwen:danwen /mnt/veracrypt1
sudo chmod -R ugo+rw /mnt/veracrypt1

I don’t understand how it used to have no issue and now it presents this permission issue and I hope I can get some guidance here. Thanks.

When you get such issue - the best answer is to recreate the container’s content in a new container.

Perhaps a change with veracrypt? I vaguely recall seeing a mention somewhere - but your own search will equal mine - so :mag:

Thank you for responding.

The issue is still unsolved.