Folders are locked, can access to them but can't delete permanently

well, here’s what I got after changing that.

sudo fdisk -l /dev/sdc
fdisk: cannot open /dev/sdc: No such file or directory

You know it’s hard to guess the letter based on the screenshoot…
Try with a instead?

sudo fdisk -l /dev/sda

So, what’s your suggestion now? Do I need to reinstall the OS? :confused:

Then you don’t have a sdc drive.
Look at the output of lsblk to see your devices.

No, as I said, it’s not directly related to your issue. Just a warning for some users.

This is what I got

lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 1.8T 0 disk
├─sda1 8:1 0 976.6G 0 part /run/media/asif/TV Series
└─sda2 8:2 0 886.5G 0 part /run/media/asif/Movies
sdb 8:16 0 931.5G 0 disk
├─sdb1 8:17 0 923.3G 0 part /
└─sdb2 8:18 0 8.2G 0 part [SWAP]

sda it is, then.

Since they’re mounted to /run/media, I guess it’s an external drive, isn’t it?

Well, it’s not an external drive. I’ve two HDD in my pc. On the sdb8:16 I’ve installed the OS. Now, looks like that the other one is being considered as an external drive.

This is the output

mkdir -p ~/hd-movies
mkdir -p ~/hd-series

sudo mount /dev/sda1 ~/hd-series
[sudo] password for asif:
Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the ‘fuser’ command.

sudo mount /dev/sda2 ~/hd-movies
Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the ‘fuser’ command.

This is the previous output

sudo fdisk -l /dev/sda
Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x84e48aab

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 2048002047 2048000000 976.6G 7 HPFS/NTFS/exFAT
/dev/sda2 2048002048 3907024895 1859022848 886.5G 7 HPFS/NTFS/exFAT

Can you try this?
Run the command in order:
Edit: wait not 3, but 2. Pinging @asifMojtoba for my mistake

sudo umount /dev/sda2
sudo ntfsfix /dev/sda2
sudo mount /dev/sda2

This will fix read-only on ntfs filesystem

Prequisite for the above commands : install ntfs-3g package (But I’m sure you have it installed already)

sudo pacman -S ntfs-3g

Optional : do this also for sda1

2 Likes

This is the first output

sudo umount /dev/sda2
umount: /dev/sda2: not mounted

sudo ntfsfix /dev/sda2
Mounting volume… OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector… OK
NTFS volume version is 3.1.
NTFS partition /dev/sda2 was processed successfully.

sudo mount /dev/sda2
mount: can’t find /dev/sda2 in /etc/fstab

This is the optional output

sudo umount /dev/sda1

sudo ntfsfix /dev/sda1
Mounting volume… The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
FAILED
Attempting to correct errors…
Processing $MFT and $MFTMirr…
Reading $MFT… OK
Reading $MFTMirr… OK
Comparing $MFTMirr to $MFT… OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition… OK
Going to empty the journal ($LogFile)… OK
Checking the alternate boot sector… OK
NTFS volume version is 3.1.
NTFS partition /dev/sda1 was processed successfully.

sudo mount /dev/sda1
mount: can’t find /dev/sda1 in /etc/fstab

This is the first output

sudo umount /dev/sda2
umount: /dev/sda2: not mounted

sudo ntfsfix /dev/sda2
Mounting volume… OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector… OK
NTFS volume version is 3.1.
NTFS partition /dev/sda2 was processed successfully.

sudo mount /dev/sda2
mount: can’t find /dev/sda2 in /etc/fstab

This is the optional output

sudo umount /dev/sda1

sudo ntfsfix /dev/sda1
Mounting volume… The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
FAILED
Attempting to correct errors…
Processing $MFT and $MFTMirr…
Reading $MFT… OK
Reading $MFTMirr… OK
Comparing $MFTMirr to $MFT… OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition… OK
Going to empty the journal ($LogFile)… OK
Checking the alternate boot sector… OK
NTFS volume version is 3.1.
NTFS partition /dev/sda1 was processed successfully.

sudo mount /dev/sda1
mount: can’t find /dev/sda1 in /etc/fstab

Weird it should be successfully unmounted…
Anyway, does it work now when you try to delete the file again (using root or chmod or chown or whatever) ?


Google searching for this issue, you need to disable fast startup in your windows OS. But since you don’t have it anymore, I don’t know what else to do for this. But by the looks of it, it seems the ntfs partitions was processed successfully. So I’m sure it will be fine…

This one worked. The problem is solved. :slight_smile:

Never been so happy in my life before. Thank you so much.

1 Like

Oh cool! Glad I could help!
:kissing_closed_eyes:

1 Like

Wha you did? I’m having the same problem, can read the files from my windows partition but can’t edit it

1 Like

Thank you so much it was fastboot reenabled after the last cumulative update in windows

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.