Flatpak Viber Crash when starting

I’m not sure when did this start. But I guess somewhere between the last two updates.
Viber doesn’t start, and crash with this error message

Gtk-Message: 20:30:51.554: Failed to load module "xapp-gtk3-module"
Gtk-Message: 20:30:51.554: Failed to load module "xapp-gtk3-module"
Gtk-Message: 20:30:51.554: Failed to load module "canberra-gtk-module"
Gtk-Message: 20:30:51.555: Failed to load module "canberra-gtk-module"
Qt: Session management error: Could not open network socket
sh: line 1: xdg-mime: command not found
xkbcommon: ERROR: Couldn't process include statement for 'ara(qwerty)'
xkbcommon: ERROR: Abandoning symbols file "(unnamed)"
xkbcommon: ERROR: Failed to compile xkb_symbols
xkbcommon: ERROR: Failed to compile keymap
[2:21:1101/203051.769295:FATAL:xkb_keyboard_layout_engine.cc(652)] Keymap file failed to load: ara,us-qwerty,

I’ve narrowed it down to being having two keyboard layout, and it indeed is the cause since removing one would make it work.
However, removing and re-adding a new keyboard layout is a hassle.
So how to fix it?

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Do you have xdg-utils installed?

Yeah, it’s installed.
I can get Viber to work by simply having single keyboard layout.
So I’m pretty sure that’s the issue, I’m not sure how to get around that though.

You can try the appimage from their site to see if that makes a difference.

This would seem relevant then, as would information about your keyboard setup…

Where is ara(qwerty) being included from?

setxkbmap -print -verbose 10
ls /usr/share/X11/xkb/symbols

This is the output of

setxkbmap -print -verbose 10

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     ara,us
variant:    qwerty,
options:    grp:ctrl_alt_toggle
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+ara(qwerty)+us:2+inet(evdev)+group(ctrl_alt_toggle)
geometry:   pc(pc105)
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+ara(qwerty)+us:2+inet(evdev)+group(ctrl_alt_toggle)"	};
	xkb_geometry  { include "pc(pc105)"	};