Flatpak Unprivileged user namespaces disabled when starting MS Edge

While attempting to start Microsoft Edge today, which is installed with flatpak, I got the following dialog

Normally I’d try to solve this myself by following the instructions in the dialog, but I feel that I shouldn’t because I am not running a “hardened” kernel, and this dialog assumes that I am. However, I am using Manjaro’s 6.1.81-5. Other flatpaks (e.g. nheko) seem to work fine as well… I’m afraid this is also a bit too technical for me and it is not clear to me what these commands actually do. How should I proceed?

My other laptop which is running the 5.15 kernel does not have this problem, but I’m not sure why

Also, just to get it out of the way, I’m using MS Edge for work stuff, it works well for that because work is a Microsoft shop, and I got my settings sync there. So I don’t want to switch to another browser.

You could install Edge from the AUR instead of flatpak.

With this said, I find it highly disturbing if a closed-source program requests me to “lower the security”. But that’s offtopic.

please don’t post images of text - unnecessary use of server space

I believe everything you need to know on security is found Security - ArchWiki

especially the [sandboxing applications] section