Flatpak QT apps don't use my theme

Hello, today I installed Kate program from flatpak, tried to run it but it doesn’t use my current qt5ct theme.
Here is how it looks:

And here’s how it’s supossed to look:

And this is what logs say:

QApplication: invalid style override 'adwaita-dark' passed, ignoring it.
	Available styles: Breeze, Windows, Fusion

AFAIK that’s an expected behavior with Flatpaks: since they don’t access your system by default, they also can’t use your theme configuration by default.


Yea except I have overrides letting flatpak reach my themes (works for gtk at least)


am i missing something?

I guess the environment variable telling Qt to use qt6ct, which you should have in ~/.profile.

can I somehow use qt5ct for qt5 apps and qt6ct for qt6?

I believe qt6ct manages both now.

Same result, below my ~/.profile file


A small update, i installed kvantum with libadwaita theme from aur, everything works but not for all apps (like kate for example)
which is inconsistent

Workaround: Use KvLibadwaita theme for consistency, you can find it on github.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.