Flatpak Apps in "Phone Mode"

Good Evening,
Last couple of days with two systems, when I run apps that are Flatpaks and use GTK, they appear in Phone Mode. All the text is in a long column in the middle of the Window. Resizing the windows doesn’t help. I confirmed its just flatpaks by reinstalling an application from the AUR instead of Flathub and it helped. Was wondering if anyone else has seen this.
Thank You.

Edit: I did discover that is related to Wayland. If i use X11, no issues.

I dont know about this issue itself… though it feels familiar…

For now a workaround might be

flatpak run --socket=x11 $application

where $application is equal to whatever you want to run.

Tried it and no dice. Everything stays in a nice column in the middle…

Ah, here is something. I used Flatseal to disable wayland and that seemed to have done the trick. Did the same for Bottles. why the --socket=x11 didn’t do the trick I have no idea but at least we have an idea why.