Flatpak application theming in Manjaro


I am using Manjaro Sway Edition and I recently setup flatpak in my system to work with pamac. I am having the problem that the flatpak applications do not match with my sway theme, which seems to be “Matcha Dark Sea”.

I made some research and according to some websites, I need to install the same theme from flatpak/flathub. The problem is “Matcha Dark Sea” does not seem to be available for me to install. There are two themes available in the flatpak repos though: “Matcha Sea” and “Matcha Azul”.

Is there any other way to setup flatpak applications to follow up the “Matcha Dark Sea” default theme? I really like this theme; however, if I can’t, I would be also ok with any of the other two themes provided they work with flatpak applications.

The flatpak applications I prefer are mostly gtk based; though I want to install one or two qt based flatpak applications.

In case I have to switch to Matcha Sea or Azul; I need help in changing my Manjaro Sway theme accordingly. How can I change my system theme and waybar theme accordingly if I have to change?

I don’t know about these flatpak themes, but usually GTK themes come in two flavors: light and dark. As such the default theme in Manjaro ARM Sway is just the ‘dark’ variant of the Matcha Sea theme. So eventually it is sufficient to install the flatpak package for it - assuming that it will contain both flavors. How to activate the theme (and especially the dark variant) for the flatpak applications is a story of its own I guess…

The current theme settings in my Manjaro Sway Machine show below:

Customize Look and Feel: “Matcha-dark-sea”
Kvantum Manager: “Matchama-dark”

I know in Gnome you can set a “dark” variant of a theme by choosing “use dark version” or similar setting in Gnome tweak tool. However, I can’t see anything similar here.

I had good success in setting up flatpak and making it to work in Debian Gnome by a similar method: Choosing a theme from gnome tweak tool and install the same theme from flatpak. After that, the flatpak applications were matching my preferred theme.

I am hoping success with a similar approach. One potential problem is that I can’t see “Matcha-dark-sea” in the flathub repositories. I see “Matcha-sea” and azul.

I am still not sure if it could also work with QT applications though.

If there are other workarounds to the problem, I would be appreciative to learn.

Maybe this tutorial will be helpful:

Thank you for letting me know about the tutorial. I tried the recipe but I was not successful unfortunately.

The application I tried is Solanum, a pomodoro timer for Gnome. I assume it is gnomt/gtk origin. I copied the settings ini to the apps’ folder in .var/app/… No difference I observed.

Flatpak is nice to have and I was using it with my Debian installation. I think I would prefer it over AUR in my pinebook pro.

I might consider switching to Matcha-Sea or Matcha-dark-azul; however, I am on Manjaro Sway and switching theme is not that straightforward. I will need some guidance for this.

Coming back to my original proposal…

Did you try to install the matcha-sea theme in Flatpak and see how the system behaves?

Ok, I tried setting up Matcha-Sea from “Customize Look and Feel” program in Sway; then I installed “Matcha-Sea” from the flathub. I open the Solanum again to see if it picks: No it doesn’t. The program is still referring to the “Adwaita” theme of Gnome, which I believe is the default/fallback theme.

I am not really sure how to setup the Manjaro theme because after a reboot, I realize that the them automagically reverted back to the original “Matcha-dark-sea”. So, I don’t know how to switch the theme.

I know there is another thread here regarding the issue of making the theme persistent. I am not sure if they are related.

I am staying away from flatpak until I learn how to setup the theming. I will stay with AUR in the meantime.