Flatpak app having squares instead of emojis (noto emoji fonts installed)

Where does flatpak keep its fonts?

I have noto emoji fonts installed in my system that is using xfce.

But one flatpak app (viber) is still not displaying them.

I tried including Noto emoji font file in


but that didn’t help either.

Reminds me of this?

Fonts are available in sandboxed flatpak here:

  • /usr/share/fonts/run/host/fonts
  • /usr/local/share/fonts/run/host/local-fonts
  • ~/.local/share/fonts/run/host/user-fonts

So viber should normally be able to catch them. Default would be:

$ flatpak run org.freedesktop.Sdk
[📦 org.freedesktop.Sdk ~]$ ls /usr/share/fonts/noto-emoji/

I get

error: app/org.freedesktop.Sdk/x86_64/master not installed

or this:

flatpak run --command=sh --devel com.viber.Viber

Still the same

error: runtime/org.freedesktop.Sdk/x86_64/23.08 not installed

I’m not sure what this even means. What kind of sdk and what to install if there is one? Thanks.

flatpak install org.freedesktop.Sdk/x86_64/23.08

Anyhow… Viber is responsible for their App. If it just take the default fonts in freedeskop, then it is their decision. I personally see no possibility to fix it on the user side.

In the AUR, there is also Viber, which should use the system fonts:

pamac buid viber
1 Like

You’re right, but aur package doesn’t work. Doesn’t even start.

viber: error while loading shared libraries: libsnappy.so.1: cannot open shared object file: No such file or directory

I’m so done with this Viber app. I will leave the flatpak one without noto emojis. At least it’s working.

Update: Installed separately snappy package and it’s working… Luckily I read the arch/aur comments.

Still don’t have emojis, even in Aur. :smile: :sweat_smile:

I’m starting to think I miss something else too…

I installed noto-emojis and joypixels.