Flashing underscore whenever I try to switch back from xanmod or lqx kernels back to latest Manjaro kernel

Hey! I have been using Manjaro for 6-7 months now and decided that I want to switch from custom kernels such as xanmod and lqx to ordinary Manjaro ones. However, I encounter flashing underscore on boot, and I am able to enter advanced grub options and switch back to custom kernels (they work straightaway). I suspect that the main problem here is the fact that I am using a Nvidia card with proprietary drivers, but not really sure how to solve this problem. Could you please help me with this issue?

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI

please post the output of

inxi --admin --verbosity=7 --filter --no-host --width

and

echo $XDG_SESSION_TYPE

and

glxinfo | grep server

note: you have to install the package “mesa-utils” first if glxinfo is missing

You need to build the Nvidia drivers as Manjaro does not provide these kernel, and of course doesn’t provide the Nvidia modules either. Not sure about your system (need to provide relevant info just saw the link to inxi), but this is probably that.

PS: there is no real benefit in using these custom kernels in my opinion. Real life use case you’ll see no difference.

inxi : inxi --admin --verbosity=7 --filter --no-host --width - Pastebin.com

Session type: tty ( x11 when using xanmod or lqx)

Glxinfo: unable to open display

Exactly! That is why I decided to get rid of them, but unable to switch to default kernel for some reason.

so please provide us with the information of glxinfo as explained above. also please use the formatting that is described below and not pastebin or any other similar.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

:+1:

glxinfo | grep server
Error: unable to open display

inxi --admin --verbosity=7 --filter --no-host --width                                                                                                                                                                                                                         
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
       LANGUAGE = "",
       LC_ALL = (unset),
       LC_ADDRESS = "en_US.UTF-8",
       LC_IDENTIFICATION = "en_US.UTF-8",
       LC_MEASUREMENT = "ba_RU.UTF-8",
       LC_MONETARY = "en_US.UTF-8",
       LC_NAME = "en_US.UTF-8",
       LC_NUMERIC = "en_US.UTF-8",
       LC_PAPER = "en_US.UTF-8",
       LC_TELEPHONE = "en_US.UTF-8",
       LC_TIME = "en_US.UTF-8",
       LANG = "en_US.UTF-8"
   are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
System:
 Kernel: 5.19.4-lqx1-1-lqx arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
   parameters: audit=0 intel_pstate=disable hpet=disable
   rcupdate.rcu_expedited=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-lqx
   root=UUID=a3094c92-0756-43f6-b54d-db1ccf235d71 rw rootflags=subvol=@
   mitigations=off quiet splash rootfstype=btrfs lpj=3499912
   raid=noautodetect elevator=noop mitigations=off preempt=none nowatchdog
   audit=0 resume=UUID=5cceecc5-7c0a-423d-b9d4-9adba01d323b
 Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
   Distro: Manjaro Linux base: Arch Linux
Machine:
 Type: Desktop System: GIGABYTE product: AORUS 15P XD v: 993AD
   serial: <superuser required>
 Mobo: N/A model: AORUS 15P XD serial: <superuser required> UEFI: American
   Megatrends LLC. v: FB06 date: 09/06/2021
Battery:
 ID-1: BAT1 charge: 94.2 Wh (95.2%) condition: 99.0/99.0 Wh (100.0%)
   volts: 16.7 min: 15.2 model: GIGABYTE Aero 15 type: Li-ion serial: N/A
   status: not charging
Memory:
 RAM: total: 15.38 GiB used: 5.76 GiB (37.5%)
 RAM Report: permissions: Unable to run dmidecode. Root privileges
   required.
CPU:
 Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
   arch: Tiger Lake gen: core 11 level: v4 built: 2020 process: Intel 10nm
   family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
 Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
   L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
   L3: 24 MiB desc: 1x24 MiB
 Speed (MHz): avg: 3211 high: 4202 min/max: 800/4600 scaling:
   driver: intel_pstate governor: performance cores: 1: 4200 2: 3633 3: 3767
   4: 2271 5: 800 6: 4200 7: 3628 8: 4104 9: 4195 10: 4111 11: 4202 12: 1662
   13: 1893 14: 4200 15: 3713 16: 800 bogomips: 111997
 Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
   arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
   avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
   avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
   cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
   cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
   flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
   hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt invpcid
   invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
   movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
   pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
   rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
   sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
   tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
   vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
 Vulnerabilities:
 Type: itlb_multihit status: Not affected
 Type: l1tf status: Not affected
 Type: mds status: Not affected
 Type: meltdown status: Not affected
 Type: mmio_stale_data status: Not affected
 Type: retbleed status: Not affected
 Type: spec_store_bypass status: Vulnerable
 Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
   usercopy barriers only; no swapgs barriers
 Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
   PBRSB-eIBRS: Vulnerable
 Type: srbds status: Not affected
 Type: tsx_async_abort status: Not affected
Graphics:
 Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Gigabyte driver: i915
   v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
   active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, HDMI-A-1
   bus-ID: 00:02.0 chip-ID: 8086:9a60 class-ID: 0300
 Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Gigabyte
   driver: nvidia v: 515.65.01 alternate: nvidiafb,nouveau,nvidia_drm
   non-free: 515.xx+ status: current (as of 2022-08) arch: Ampere code: GAxxx
   process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
   lanes: 16 ports: active: none off: DP-6 empty: HDMI-A-2,eDP-2
   bus-ID: 01:00.0 chip-ID: 10de:249d class-ID: 0300
 Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
   bus-ID: 3-9:4 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
 Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
   compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
   gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
 Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
   s-diag: 1245mm (49.01")
 Monitor-1: DP-6 mapped: DP-1 note: disabled pos: primary,top-right model: LG
   (GoldStar) ULTRAGEAR serial: <filter> built: 2021 res: 2560x1440 hz: 144
   dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
   ratio: 16:9 modes: max: 2560x1440 min: 640x480
 Monitor-2: eDP-1 mapped: eDP-1-1 pos: bottom-l model: Sharp LQ156M1JW03
   built: 2019 res: 1920x1080 hz: 240 dpi: 142 gamma: 1.2
   size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
   modes: 1920x1080
 OpenGL: renderer: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2 v: 4.6.0
   NVIDIA 515.65.01 direct render: Yes
Audio:
 Device-1: Intel Tiger Lake-H HD Audio vendor: Gigabyte driver: snd_hda_intel
   v: kernel bus-ID: 3-2:2 chip-ID: 0ecb:1f52 alternate: snd_sof_pci_intel_tgl
   bus-ID: 00:1f.3 class-ID: 0300 serial: <filter> chip-ID: 8086:43c8
   class-ID: 0403
 Device-2: NVIDIA GA104 High Definition Audio vendor: Gigabyte
   driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
   bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
 Device-3: JBL Quantum 300 type: USB
   driver: hid-generic,snd-usb-audio,usbhid
 Sound Server-1: ALSA v: k5.19.4-lqx1-1-lqx running: yes
 Sound Server-2: JACK v: 1.9.21 running: no
 Sound Server-3: PulseAudio v: 16.1 running: yes
 Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
 Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
   pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 2e:00.0
   chip-ID: 10ec:8125 class-ID: 0200
 IF: enp46s0 state: down mac: <filter>
 Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
   speed: 5 GT/s lanes: 1 bus-ID: 30:00.0 chip-ID: 8086:2723 class-ID: 0280
 IF: wlp48s0 state: down mac: <filter>
 Device-3: NetGear Nighthawk A7000 802.11ac Wireless Adapter AC1900
   [Realtek 8814AU] type: USB driver: rtl8814au bus-ID: 3-4.1:5
   chip-ID: 0846:9054 class-ID: 0000 serial: <filter>
 IF: wlp0s20f0u4u1 state: up mac: <filter>
 IP v4: <filter> type: dynamic noprefixroute scope: global
   broadcast: <filter>
 IP v6: <filter> type: noprefixroute scope: link
 IF-ID-1: docker0 state: down mac: <filter>
 IP v4: <filter> scope: global broadcast: <filter>
 WAN IP: <filter>
Bluetooth:
 Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
   bus-ID: 3-10:6 chip-ID: 8087:0029 class-ID: e001
 Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Logical:
 Message: No logical block device data found.
RAID:
 Message: No RAID data found.
Drives:
 Local Storage: total: 953.87 GiB used: 469.71 GiB (49.2%)
 SMART Message: Unable to run smartctl. Root privileges required.
 ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Phison
   model: ESR01TBTLG-E6GBTNB4 size: 953.87 GiB block-size: physical: 512 B
   logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
   rev: EGFM13.0 temp: 53.9 C scheme: GPT
 Message: No optical or floppy data found.
Partition:
 ID-1: / raw-size: 936.66 GiB size: 936.66 GiB (100.00%) used: 464.78 GiB
   (49.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
   uuid: a3094c92-0756-43f6-b54d-db1ccf235d71
 ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 568 KiB
   (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: NO_LABEL
   uuid: AA15-6192
 ID-3: /home raw-size: 936.66 GiB size: 936.66 GiB (100.00%) used: 464.78
   GiB (49.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
   uuid: a3094c92-0756-43f6-b54d-db1ccf235d71
 ID-4: /var/cache raw-size: 936.66 GiB size: 936.66 GiB (100.00%)
   used: 464.78 GiB (49.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
   label: N/A uuid: a3094c92-0756-43f6-b54d-db1ccf235d71
 ID-5: /var/log raw-size: 936.66 GiB size: 936.66 GiB (100.00%) used: 464.78
   GiB (49.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
   uuid: a3094c92-0756-43f6-b54d-db1ccf235d71
Swap:
 Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
 ID-1: swap-1 type: partition size: 16.91 GiB used: 4.93 GiB (29.1%)
   priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 label: swap
   uuid: 5cceecc5-7c0a-423d-b9d4-9adba01d323b
Unmounted:
 Message: No unmounted partitions found.
USB:
 Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
   speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
 Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
   chip-ID: 1d6b:0003 class-ID: 0900
 Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
   speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
 Device-1: 3-2:2 info: JBL Quantum 300 type: Audio,HID
   driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
   speed: 12 Mb/s power: 500mA chip-ID: 0ecb:1f52 class-ID: 0300
   serial: <filter>
 Hub-4: 3-4:3 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s
   power: 100mA chip-ID: 1a40:0101 class-ID: 0900
 Device-1: 3-4.1:5 info: NetGear Nighthawk A7000 802.11ac Wireless Adapter
   AC1900 [Realtek 8814AU] type: Network driver: rtl8814au interfaces: 1
   rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0846:9054 class-ID: 0000
   serial: <filter>
 Device-2: 3-4.2:7 info: Corsair Harpoon Wireless Mouse type: Mouse,HID
   driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
   power: 500mA chip-ID: 1b1c:1b5e class-ID: 0300 serial: <filter>
 Device-3: 3-4.3:9 info: SINO WEALTH RK Bluetooth Keyboar
   type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 1.1
   speed: 12 Mb/s power: 500mA chip-ID: 258a:0064 class-ID: 0300
 Device-4: 3-9:4 info: IMC Networks USB2.0 HD UVC WebCam type: Video
   driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
   chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
 Device-5: 3-10:6 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
   interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
   class-ID: e001
 Device-6: 3-11:8 info: Chu Yuen Enterprise USB-HID Keyboard
   type: Keyboard,HID driver: hid-generic,usbhid interfaces: 4 rev: 1.1
   speed: 12 Mb/s power: 100mA chip-ID: 1044:7a3f class-ID: 0300
   serial: <filter>
 Hub-5: 4-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 20 Gb/s
   chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
 System Temperatures: cpu: 59.0 C mobo: N/A gpu: nvidia temp: 53 C
 Fan Speeds (RPM): N/A
Info:
 Processes: 411 Uptime: 1h 6m wakeups: 1 Init: systemd v: 251
 default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
 Packages: 1546 pm: pacman pkgs: 1522 libs: 410 tools: pamac pm: flatpak
 pkgs: 24 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: yakuake
 inxi: 3.3.21


i’m out

I don’t understand what am I doing wrong, sorry.

provide output from:
mhwd-kernel -li

It should be enough to install the current kernel sudo mhwd-kernel --install linux519 and then your nvidia drivers.

Your kernel parameters don’t look default, please remove anything that you don’t actually need (e.g. audit=0 is listed twice)

From the blinking cursor, can you switch to a TTY? Then you could also provide the journal of this boot and the Xorg.0.log file.

1 Like

Hi, I will post another reply as soon as I will be back home. So far I have tried linux 515 and it works without any issue, while booting in 519 produces kernel panic. I am able to use TTY without any issues as well.

The kernel and the gpu drivers are meant for eachother. If your combination is not built to match you will get issues.

You are - of course - aware the mentioned kernels are custom built and unsupported.

If you like to play with kernels - I get it - I do too - from time to time.

I therefore suggest you ensure you install kernel headers for whichever kernel and nvidia-dkms - I think this will take the top of your issues.