Flashing cursor on black screen for a few seconds then disappears

Yesterday 24th April I updated Manjaro running Xfce.
After about 20 minutes of using firefox and Brave, they crashed.
I opened them up and Brave crashed but Firefox froze with just a loop in in the sound.
I rebooted and that’s when the black screen started BUT this time the flashing cursor would last for a few seconds and then appear again.
The hdd is constantly running like it’s in a loop.
On the black screen I press Ctrl+ Alt+ F2 and I get the TTY but again only for a few seconds then it disappears.
I have pressed E to edit Grub options and added 1 at the end of the Linux line then F10
At boot it displays these messages again for a few seconds
[FAILED] Failed to start Load/Sae Randone Seed
Then after a few seconds
[FAILED] Failed to start Load/Sae Randone Seed
[FAILED] Failed to start Record System Boot/Shutdown in UTMP
[FAILED] Failed to start Load/Sae Randone Seed
[FAILED] Failed to start Record System Boot/Shutdown in UTMP

Then it goes blank with the cursor flashing for a few seconds and dissappears then comes back.

I’ve edited the Grub with options 1 to 6 and I get the same error.

I’ve tried a Live USB and when I went into a terminal and typed manjaro-chroot -a it couldn’t find any Linux partions.

Any help will be appreciated.
Kind regards

do you have disabled secure boot and TPM - trusted platform module in bios?

Secure Boot is Other OS and it has always been that way as I have Windows 10 on another HDD
I couldn’t find TPM
The motherboard I am using is an Asus Sabertooth R2 FX990 about 10 years old.

you still should disable the secure boot and try if the issue persist… you can reenable it again later
also try adding this random.trust_cpu=on line to your kernel parameters in grub…
both secure boot disabled and the kernel parameter should be used, so try it

I’m having to reply on a back up Win OS as I need to teach Online for some students in the next 20 minutes.
Tonight, I will do what you have asked and update you.
Thanks again and kind regards.

before messing with bios/ kernel parameters, try first running your system with different kernels, for example: kernel 5.15.32-1 and kernel 5.10.109-1 and see

As I have a few mins, how do I try different kernels if I can’t even get into TTY?
TTY only shows up for a few seconds and then disappears.
Kind regards

oh, i thought you could boot into your system, so first try the bios/kernel parameter thing, if it doesnt work, youll have to use a live usb of manjaro and chroot into your install, and install kernels from there

No worries.
I did try a Live Manjaro from a usb.
I tried manjaro-chroot -a and it couldn’t find any linux partions and I have 2 of them.
Kind regards

so if those bios/kernel dont work youll probably have to use use chroot anyway:
sudo manjaro-chroot -a
and copy the whole output here

Booted live Manjaro usb
terminal: sudo manjaro-chroot -a
grub-probe:error:Cannot find a GRUB drive for /dev/sdf1 Check your device.map
grub-probe:error:Cannot find a GRUB drive for /dev/sdf1 Check your device.map
==>ERROR: No Linux partions detected!

isnt this: grub-probe:error:Cannot find a GRUB drive for /dev/sdf1 Check your device.map from the live usb, so its normal …
try first disabling the bios settings - secure boot, and disable also fast boot… this really looks like a bios issue…

On the bis secure boot it has only two options
Windows or Other OS
It does not have another option to diable.
I will disable fast boot and see what happens.

yes try disabling the fast boot and select the other os in secure boot

It has always been in Other OS.

so did you disable the fast boot and tried it…
youll probably need to disable secure boot directly from windows

Strange. Can you post a bit more information?

inxi -Fazy
lsblk --fs
sudo parted -l

Hello everyone,
Before doing anything with BIOS or Windows, I went through TimeShift and saw my recent backups were yesterday before the update.
Restored the latest backup which was just seconds and Manjaro is booting up fine.
Just looking at the updates that may have caused the trouble.
I see lib32-libva-mesa-driver

Now I have the AMD RX580 8GB GPU.
Do I need lib32-vulkan-intel and radeon drivers?
What does intel have to do with vulkan?
Anyway, thanks for all your help and kind regards

doesnt make sense that updating these caused the issue, but you never know with linux…
i have nvidia, and have radeon vulkan drivers… so just keep them…