Flash Manjaro Gnome on the Radxa Zero


I want to use Manjaro on my Radxa Zero. But I can’t flash it to the eMMC.
The img file I use is Manjaro-ARM-gnome-radxa-zero-20210906.img

Is there any tutorial or something of how to do this?
I flashed it with BalenaEtcher, reconnected the device and it doesn’t boot. What am I doing wrong?

Check if Manjaro supports the platform.

This can usually be deducted from the download page.

Currently, Manjaro does not work from the eMMC on the Radxa Zero. Only from SD card.

Ah ok. I read that is bootable on the SD Card. Is Android on the eMMC required?

Do you know when a version will be released who runs on the eMMC?

@spikerguy can answer better, but I do believe android is required on the eMMC for now.

1 Like

Yes for current Radxa Zero Images it is required.

You can follow the steps I have documented here

1 Like

@spikerguy I don’t made it to install android on the eMMC. I installed Armbian 21.08.0 instead. Manjaro also booted with a SD Card and the Armbian on the eMMC. Then I executed sudo /boot/install-aml-emmc.sh and from time to time there was some messages that some time stamps are in the future. I don’t know if this is bad but the command runs and ends successfully.
Then I tried to boot without SD card but it only shows the Manjaro loading screen. I let it run for over half an hour but nothing changes. Is it normal that it takes to much time or is there something?

Before running this script you need to make sure the time is updated.

Ah this can be due to 2 reasons.

  1. Files transfer in the above script is skipped coz of time stamp issue.

  2. /etc/fstab still have old rootfs PARTUUID

Boot from sd card again and mount emmc and comment out line rootfs line in point 2 above. Then try to boot, if still the same then it is point 1.

Good luck.

I think I know the problem with the time. I can’t connect to the Wifi. There is nothing where I can find the available networks and nmtui doesn’t shows any network.

1 Like

Finally it worked with the latest release. https://github.com/manjaro-arm/radxa-zero-images/releases


Congratulations to the Manjaro team for this release.

The Radxa board is simply awesome, I’m using it as daily driver. Yes, it works! A fully working desktop, completely silent, cool and with less than 5 watt of power consumption… :dizzy_face:

And with the flexibility and power of Manjaro it has to be amazing.

Does this version of Manjaro support restart and suspend/resume? (Not working on the Debian image provided by the Radxa team).

Is it stable?..

Is Pacman working ok? (updated to the latest app versions, support for kernel install and AUR working?)…

Thanx! :slightly_smiling_face:

1 Like

Yes it should be as the latest image is using Mainline uboot and not relying on bsp uboot. I don’t remember from my test though.

Kindly wait for the official release during next weekend.

Yes it works fine.


Thank you for your fast answer.

Is GPU acceleration working in Manjaro for Radxa Zero (3D and/or video)? Specially for Chrome (Vulkan, OpenGL / WebGL)?..

This is what about:gpu returns in Chrome 89 (debian), lots of stuff disabled:

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Compositing: Software only. Hardware acceleration disabled
Multiple Raster Threads: Enabled
Out-of-process Rasterization: Hardware accelerated
OpenGL: Unavailable
Rasterization: Hardware accelerated on all pages
Skia Renderer: Enabled
Video Decode: Software only. Hardware acceleration disabled
Vulkan: Disabled
WebGL: Unavailable
WebGL2: Unavailable

Thanx! :slightly_smiling_face:

You can find the solution here

Hi spikerguy,

Thanks for your speedy help! :slightly_smiling_face:

Chromium flags effectively enable webgl and other options but the browser becomes very sluggish.

Webgl Aquarium demo at websamples only runs at 3fps, for example.

And youtube is unusable.

Probably related with the Panfrost driver of Debian Buster…?

Can someone confirm that webgl is enabled in chromium for Manjaro (Radxa Zero)? Just type chrome://gpu in the address bar.

How many fps do you see in the Aquarium demo?

Thanx! :slightly_smiling_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.