First time user experience 1 perfect, 1 miserable

Hi, brand new here, still a bit wet behind the ears with Linux in general.
I recently bought a new Raspberry Pi 4 and went hunting for an OS a bit more serious than what accompanies the Pi. I use Mint on my other Linux machines (all recent attempts to dive into the Linux pool once again after multiple fails since the early 2000’s), but they don’t have anything for ARM; more than a little frustrating.
So, after trying pretty much everything else for ARM and having them all fail quite miserably, I landed on Manjaro. Manjaro installed MUCH faster, with zero failures or hiccups, did so onto an SB card and then onto an NvMe. Ran impressively faster than anything else and looked so good it occurred to me to install it onto one of my more serious machines and try it out instead of Mint.
At this point, a bit more background may help…
I have used Macs almost exclusively for about 3+ decades, trying on multiple occasions since the early 2000s to “bring an old computer back to life” with Linux. That very common advice has until recently been a very bad idea for newcomers, at least from my experience. (No one is likely to install Linux on a new machine that already has a new OS on it.) I started out trying Debian, then later Ubuntu, over and over and OVER again, always failing to install properly and ALWAYS getting advice that would only make sense to someone already experienced with Linux. The biggest problem was ALWAYS the wireless driver(s). I lost count of the number of times I had to give up on Linux for that reason alone.
Within the last few months, Mint finally solved all that, but there is no way I am going to run two very different distros of Linux, if I can avoid it, because I have to run at least one Mac. (Trying to ditch Macs as much as possible. They have just gotten too greedy AND they abandon older users which is apparently, also the case with Manjaro(?), making it appear that Manjaro may be a bad choice.)
I seem to recall (could be wrong) reading somewhere that Manjaro does not share the interest in supporting older machines that the Mint folks have, and that would appear to be true. (I have installed mint multiple times on multiple machines, new and old, without ever the slightest problem.)
I installed Manjaro on a late 2012 i5 Mac Mini (SSD + 16 Gigs) and Manjaro simply refused to see the 5G wireless or ethernet connnections that every other computer, phone, security camera system and dog collar I own does see without any help from me. It did see the slower 2.5G ethernet, which of course is pretty much useless.
A recent (2018) Mac is still my primary work machine, until Photoshop (yes, I know about Gimp, it won’t do at all) and Filemaker Pro (another absolute necessity) are ported over to Linux, neither of which occurrences seem to be in the stars.
Has Manjaro really made the decision to just not support older machines, making it impossible for me (and anyone else who uses old AND new machines, which is almost everybody) to consider moving to Manjaro? Please tell me that whatever I read, or perhaps just imagine that I read, is not correct. If I am going to make this transition, I need an OS I can depend on to not abandon me because it doesn’t like older machines, and one that does not push me into a repetition of my experiences of the past, i.e., going through command line entry after command line entry found on the internet, all obsolete, and all on web pages with no date to indicate the possibility of obsolescence. Every suggestion I found on the internet years back for both Debian and Ubuntu to supposedly solve their problems with wireless, failed to work, but DID make changes to my systems that I could not undo. I refuse to go through all of that again. A GUI based solution would be vastly preferable.

Thanks, I’ll go through that. At least the page has a date on it! That alone is refreshing.
But, what about ethernet? Why does Manjaro not see that connection, at all? Surely, that should be a no-brainer?

Apple branded hardware is created for macOS.

Running Manjaro on Apple branded hardware is unsupported.

I have had bad result with an old Apple Mini (AFAIR it was 32-bit) and a macBook Pro 2017 (touch strip)

Manjaro works fine on the Pi - be aware that several tools available in RaspberryPi OS is not available in Manjaro. Also remember that Pi is low cost single board computer - don’t expect a racehorse.

Yes - you could say that.

Besides the ARM devices - Manjaro only supports 64bit x86.

Upstream Arch dropped i686 late 2017 and Manjaro is based on Arch so it reflected.

There was a community inititive to keep i686 running and it was available for about a year or two and eventually shut down.

I have Manjaro KDE running fine on a PC I built in 2013. I think all of your issues are likely due to the Apple hardware.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.
P.P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

Apple hardware, until just recently, has been Intel based, so is the 2018 Mac Mini. But I am not running Linux on that. As stated, I need to run Manjaro on a 2012 Mini. Linux supports running on pretty much every X86 64bit platform, which includes Mac, or am I wrong? I am running Mint flawlessly on multiple Macs. Broadcom runs on both Macs and Windows machines does it not?
Nothing I have is 32 bit.
Also, you are the very first person to tell me that Linux shouldn’t run on a Mac. They certainly run Windows just fine, both direct and emulated. Perhaps you have been misinformed about Macs?
My interest in Manjaro stems from the observation that, compared to other systems on the Pi, Manjaro IS a racehorse on the Pi.

I can’t do that right now. I am currently running Manjaro only on the Pi, and don’t want to install it on any X86 machines again until I know I can depend on it to work with wireless and that functionality won’t be taken away from me in the future. That’s what Apple has done to me.

Yes that includes Mac - but only for as far as it is specific batches of specific Intel CPU’s and you cannot generalize computerhardware that way.

I cannot say what it is with Apple but one could suspect they are protecting their brand by creating technical obstacles for the sole purpose of ensuring that only macOS is running smooth on the hardware - but that is a guess without anything to found it on.

Most notably is Apples use of Broadcom and not all Broadcom devices work equally well with Linux.

There is a lot of hardware which only works well under Windows and is a pain to get running using Linux and wireless network cards is a group of hardware where it is not everything that work OOB.

If you lean to the fact that Apple is BSD fork then you would have more success using a BSD instead of Linux.

Apple hardware is created for macOS and it requires talent and persistence to overcome all obstacles which will surface when you are trying to use Linux on Apple branded hardware.

You might find the following helpful:

as @linux-aarhus already stated, installing linux onto an mac is a little bit fiddling and takes time and research. it’s up to you if you’re willing to do that but to be clear manjaro is a rolling release distribution and you must not expect to get a all-inclusive-pain-free installation if you’re using such distros regardless if it’s a mac or an ordinary pc. there are LTS-Distros that fit this demand better.
Nevertheless if you use the search engine of you’re choice with “manjaro mac mini 2012” you will find further information like this one as example:

OK, I went ahead and installed Manjaro on a Mac Mini (also a late 2012), that has a BCM43xx wireless card. I read through the paper you linked to and ran into the same problem I ran into years ago. That page was written for people who are already expert Linux users and probably don’t need that page. I could make some sense out of it, managed to run dmesg in a terminal and found this line: “b43-phy0 warning: 5ghz band is unsupported on this PHY”
However, finding that pretty much tells me what I already knew, and does nothing to solve the problem. The rest of the page gives instructions to do this and do that, none of which exercises are explained, at all.
I would reiterate, I have installed Mint with zero hiccups on three of these Mac Minis and on a recent HP laptop, so the statements that Linux “doesn’t support” this Broadcom hardware are just silly. Obviously SOME versions of Linux do, and quite easily and transparently. It just worked, over and over! The advice that I only vaguely understood on that page, all seems to be suggesting that I meddle with the Kernel, which I am definitely NOT going to do.
BTW, the comment about Apple protecting their hardware, I completely agree with. They have gotten to the point where I have the same loyalty to them that they have for me: none at all!
Unless there is a fix to this problem that the common user can install, that is, me, I will have to forego Manjaro until it catches up with Mint, which apparently, based on what was said, they have no intention of doing.

Thanks but that page is about creating a dual boot machine which I have already done with Mint and don’t want to do with Arch, where I want a single boot machine. Also, that is an all-command-line install. I went through that years ago with Debian and then Ubuntu. No way. If anything goes wrong, and it will, the error messages will be gibberish to me. Command line installs are only for people who already know how to do it.

Kinda like installing Linux on a Mac, huh?