Firmware Bug | tpm_crb MSFT0101:00

acpi

#1

Hello first!

I’ve been noticing that in the boot-screen there’s a message about a bug that i thought it was some BIOS bug, but after updating it the problem persists. I also tried more recent kernels but it did nothing.

dmesg | grep tpm_crb

[    7.167566] tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080f80
[    7.168666] tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080f80

inxi -Fxz

System:
  Host: X556UQK Kernel: 4.14.53-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.1 Desktop: MATE 1.20.0 Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:
  Type: Laptop System: ASUSTeK product: X556UQK v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X556UQK v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X556UQK.313 date: 03/13/2018 
Battery:
  ID-1: BAT0 charge: 19.5 Wh condition: 30.7/38.0 Wh (81%) 
  model: ASUSTeK ASUS Battery status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23240 
  Speed: 500 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
Graphics:
  Card-1: Intel HD Graphics 620 driver: i915 v: kernel bus ID: 00:02.0 
  Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A bus ID: 01:00.0 
  Display: x11 server: N/A driver: intel resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) 
  v: 4.5 Mesa 18.1.3 direct render: Yes 
Audio:
  Card-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.14.53-1-MANJARO 
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k v: kernel bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  HDD Total Size: 931.51 GiB used: 21.14 GiB (2.3%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
Partition:
  ID-1: / size: 906.94 GiB used: 21.14 GiB (2.3%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 34.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 160 Uptime: 16m Memory: 5.71 GiB used: 1.16 GiB (20.3%) 
  Init: systemd Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.12

I would really appreciate help with this, although it doesn’t affect my computing.

Thanks in advance!


ASUS Z450UAK with Manjaro 18 XFCE - journald takes 90%+ of CPU and laptop freezes all the time
#2

Check here. If you don’t use the tpm module (in ex.: for secure/fast boot) you can disable it. I also have mine disabled, even-though I don’t get any error.

To disable it go to your BIOS.
Then blacklist the module under linux:

  1. create a file in /etc/modprobe.d/ (in ex.: blacklist.conf)
  2. write blacklist <module-name> (one per line).

To get the module names you need to blacklist use lsmod | grep tpm

Mine looks like this:

[mbb@mbb-laptop buildtest]$ cat /etc/modprobe.d/blacklist.conf 
# Blacklist unwanted drivers

blacklist iTCO_wdt
blacklist iTCO_vendor_support
blacklist mei_wdt
blacklist mei_me
blacklist mei
blacklist tpm_infineon
blacklist tpm_tis
blacklist tpm_tis_core
blacklist tpm
#blacklist iwlwifi

If you have Windows installed and it fails to launch after disabling tpm in BIOS, then leave it enabled and only blacklist the tpm modules.

EDIT: I’m not sure if you need to blacklist the modules if you disable it in BIOS, but it won’t do any harm anyway.


#3

It actually worked flawlessly.
Thank you very much!

PD: I don’t dual-boot so be aware. This may not be an universal solution as mbb said.


closed #4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.