Firefox will not start after update

After the latest update, Firefox will not start, until after several attempts.
Typing “firefox” in a terminal window, basically nothing happens.
Closing the terminal window, and starting a new terminal window, and typing “firefox” again.
After several attempts, during 5 to 10 minutes, there comes up a warning that Firefox was not closed correctly, and I might start in safe mode. Starting in safe mode then works.
Then I can close it and start it normally.
I can close it, and start it normally again.
There seems to be no problems at all.
But, next time I start the computer, it all repeats it self. All the problems are back again.
Even if Firefox was closed correctly, it says differently, again.
What is wrong with Firefox now ?

/ Hans Gatu

1 Like

You can try to do the following:

  1. Uninstall firefox with package manager and then reinstall again.
  2. There could be a problem with the config of firefox: rename .mozilla in your home directory to .mozillabak (firefox must not be running).

Check if you have a Firefox process running.

There is no Firefox process running, when I start the computer.
But the problem is there already, at first attempt.

/ Hans Gatu

It sounds like a corrupt profile. A majority of Firefox problems is a result of a corrupt profile. Start with a fresh profile and no extensions installed and see how it goes. Then if all is well add the extensions one by one to root out any problematic extension(s).

If the profile is corrupted, then copy the following files from .mozilla to a backup directory and
start firefox and stop the program and copy the files back to .mozilla.
The files:
cert9.db=certificates
key4.db= has to do with passwords, I don’t remember exactly, but worth backing up
logins.json = saved passwords
places.sqlite=bookmarks
prefs.js- self explanatory
search.json.mozlz4= Search engines, including custom

1 Like

Same problem!

I also recommend making a backup of the folder .mozilla (for Firefox) and .thunderbird (for Thunderbird).

I have uninstalled Firefox.
Deleted the .firefox folder.
Then reinstalled Firefox.
Firefox works now.

/ Hans Gatu

4 posts were split to a new topic: Firefox runs without interface

Of some reason, that I don’t know, the problem is back.
I have also tried a new profile, but it did not help.

/ Hans Gatu

yeah there’s no way to fix it, it always comes back. starting to really hate manjaro. Remove firefox package, install from flatpak, hopefully it should work.

I was hoping that yesterdays Manjaro update should solv the problem.
There were both an Firefox update, as well as a kernel update.
It didn’t help, though.

/ Hans Gatu

Yesterday, Manjaro had another big update, with plenty of updated packages. Among them were an updated Firefox, but also a new kernel. After that big update, Firefox works perfectly well.

/ Hans Gatu