Firefox web navigation not working after update

When I updated firefox today, all of my bookmarks stopped working, searching stopped working and the icons in the new tab menu also stopped working. When clicked, the tab would load for a split second, and then nothing would happen.
I’ve tried reinstalling, i’ve tried reinstalling + deleting every file containing the word firefox, i’ve tried refreshing databases in add/remove software.
Does anyone know a fix?

Welcome here, @nilnail

  • From where have you installed firefox, normal repos or AUR, snap, web, whatsoever?
  • How did you update it?

I installed firefox from the normal repos
I used the update utility in add / remove software

Removing ~/.cache/firefox could help.
If not, run firefox from the terminal and post the output between code brackets </>

There was no folder named firefox in /home/(user)/.cache/ although there was one named “mozilla” which contained a folder called “firefox”. Deleting it didn’t fix the problem.

When I type in firefox into terminal and then search up anything I see no terminal output, although closing firefoxs outputs:
###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
Am I doing something wrong?

Which desktop you’re running?

Gnome, i’ve tried to get firefox to work on both wayland and Xorg to no avail

for clarification: I’m not trying to fix the current install of firefox, or keep any settings in firefox. I’ve already completely reset my install of firefox in an attempt to get it working. All I need are instructions on how to make firefox work again.