Firefox very slow to start after recent update

After the most recent update, Firefox is very slow to start. Firefox itself runs fine, but it takes about 8 seconds to start, whether I run it from the terminal or from a shortcut on the desktop.

Furthermore, Firefox also exhibits this slow start behavior if I click links from other programs, such as Thunderbird and Element, even if a Firefox window is already open. Links opened within Firefox itself don’t have this issue.

When running from the terminal, I get this error:

[GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found.
ATTENTION: default value of option mesa_glthread overridden by environment.

Chromium browsers don’t have this issue.

As always with FF, the only way to troubleshoot is with a fresh profile and no extensions as 99% of FF issues come down to a corrupt profile or a misbehaving extension. I get the same message running from terminal in my main browser, FF Nightly and also with the Manjaro Distribution version. Neither version has the issue you are having. Try with a fresh profile and add extensions one by one to help see what is going on.

In addition, quoted from EndeavourOS forum:

I’ve just found out that language packs can also create 
memory leaks under certain conditions, 
so if after disabling extensions you still find issues 
then remove any language packs too 
(especially any installed via AMO (addons.mozilla.org) rather 
than the repos)

Hey there, been having the same issue. Updated today, and Firefox is taking 20-30s to start. I tried clean profile, and disabling extensions, but it didn’t change anything. Much like OP, Thunderbird shows same issue. Starting from terminal I get

[GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection.
ATTENTION: default value of option mesa_glthread overridden by environment.

If someone has some clues, that would be great (also I’m running on 16GB of RAM and never had this issue before updating).

Found it, relevant Arch forum thread Firefox suddenly painfully slow to load / Newbie Corner / Arch Linux Forums

I have removed xdg-desktop-portal-gnome and suddenly everything back to normal. If someone has an idea why this could be happening, I’m curious to know

1 Like

Its also been mentioned in every update announcement here for the last 29 days.

Ex:

this solved it for me