Firefox take near 70% of the CPU

Firefox 10x.y take all the 8 cpu I have to simply run specific website.
I tested with Chrome, Chromium and Vivaldi and the problem exist only with Firefox.
Also, I tested many of the google-help-me solution without success.

I know that this not the Nvidia driver bc I play Steam Game with very acceptable FPS and fluidity.

Is it possible that is not resolvable at all.

My config:
Testing branch
KDE Plasma 5.26.5
KDE Framework 5.101.0
Qt: 5.15.7
Nvidia: 525.78.01
up to date and recently installed

I have (re) installed my system two times with the same result.

Any idea ?

1 Like

Dunno, but I’ve found this after a quick spin around the web…and there’s plenty of info on the subject too , but you’ll have to sift through plenty it of course :wink:

PS, if you post your system output here, maybe somebody more in the know than myself might be able to help :point_up:


FYI, browser performance is not related to video game performance.



What hardware are you using ? inxi -Fza on console.

1 Like

Only that one specific site or is that a general problem?
Which site?


1 Like

Have you tried the usual when FF misbehaves? Fresh profile, no extensions, then add extensions one by one to see if an extension is causing the issue. Have you tried about:support and used any of the options there?


That could also be the problem who knows :woman_shrugging:

1 Like

This one: WebGL Aquarium

Also, I refresh Firefox and deactivate all extension, the acceleration flag is set:

inxi -Ga give:
inxi -Ga
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI
driver: nvidia v: 525.78.01 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 16
ports: active: none off: DP-1,HDMI-A-1 empty: DVI-D-1 bus-ID: 02:00.0
chip-ID: 10de:1c03 class-ID: 0300
Display: wayland server: v: with: Xwayland v: 22.1.7
compositor: kwin_wayland driver: N/A d-rect: 5593x1598 display-ID: 0
Monitor-1: DP-1 pos: right res: 2841x1598 size: N/A modes: N/A
Monitor-2: HDMI-A-1 pos: primary,left res: 2752x1152 size: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.78.01 renderer: NVIDIA GeForce GTX 1060
6GB/PCIe/SSE2 direct render: Yes

Hope at least, one of you don’t have this bug. :slight_smile:

1 Like

Resolved: Wayland is the culprit is wayland.
All problem with openl and hardware acceleration. I switched to the ‘old’ and everythings is fine.

Thank you for your help.

Then your Wayland setup is borked, because im on Wayland also:

$ inxi -G
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] driver: nvidia v: 525.60.11
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.3 driver:
    X: loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa
    gpu: nvidia,nvidia-nvswitch resolution: 2560x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.