Firefox Slow Start Time

Hey Everyone,

I am using Firefox 96.0.2 under Manjaro Gnome and for some reason when I start the browser, it seems to take 30-45 seconds before it actually launches. This is way different than the 2-3 seconds it takes to launch Brave or Chrome browsers.

Firefox is something I use occasionally for testing, so it’s not my ‘main’ browser. But I just find it strange it taking almost 1 full minute to launch on my relatively updated Manjaro Laptop (Dell XPS 13 9350 i5 with 8GB of Ram and SSD).

Full System Specs:

inxi -Faz
System:
  Kernel: 5.15.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=501de8bc-72f3-4eb8-8dd8-eb0381f16ebc ro
    resume=UUID=2314cba6-fa6e-443b-8fc2-de4d6ad99ffe apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: XPS 13 9350 v: N/A
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 076F9T v: A00 serial: <superuser required> UEFI: Dell
    v: 1.13.0 date: 02/10/2020
Battery:
  ID-1: BAT0 charge: 22.6 Wh (91.1%) condition: 24.8/57.5 Wh (43.1%)
    volts: 7.9 min: 7.6 model: SMP DELL JHXPY53 type: Li-poly serial: <filter>
    status: Discharging
CPU:
  Info: model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
    family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEA
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2771 high: 2800 min/max: 400/2800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2793 2: 2792 3: 2800
    4: 2699 bogomips: 19204
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Microdia Integrated Webcam HD type: USB driver: uvcvideo
    bus-ID: 1-5:3 chip-ID: 0c45:670c class-ID: 0e02
  Display: wayland server: X.org 1.21.1.3 compositor: gnome-shell driver:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: 0
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.15-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel bus-ID: 3a:00.0
    chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp58s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-3:2 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 4 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 238.47 GiB used: 35.57 GiB (14.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM951 NVMe 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: BXV77D0Q
    temp: 34.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 79 GiB size: 77.26 GiB (97.80%) used: 24.56 GiB (31.8%)
    fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 26.6 MiB (27.7%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-3: /home raw-size: 80 GiB size: 78.24 GiB (97.81%)
    used: 9.94 GiB (12.7%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
  ID-1: swap-1 type: partition size: 3.84 GiB used: 1.04 GiB (27.1%)
    priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
Sensors:
  System Temperatures: cpu: 52.0 C pch: 46.0 C mobo: 39.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 265 Uptime: 2d 51m wakeups: 26 Memory: 7.63 GiB
  used: 3.93 GiB (51.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1504 lib: 446 flatpak: 0
  Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.12

When I launch FIrefox in the terminal I see the following:

firefox                                                                                                                                                          ✔ 
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.

If I can provide any additional information to assist in the troubleshooting process, please let me know. Thanks in advance everyone for your time and help, it is greatly appreciated!

Does this happen in any other browser or in firefox safe mode?

firefox -safe-mode

Firefox Output:

firefox -safe-mode                                                                                                                                               ✔ 
ATTENTION: default value of option mesa_glthread overridden by environment.

Chrome-Beta Output:

google-chrome-beta                                                                                                                                               ✔ 
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[13763:13763:0122/110935.709101:ERROR:sandbox_linux.cc(377)] InitializeSandbox() called with multiple threads in process gpu-process.
[13722:13722:0122/110937.456127:ERROR:object_proxy.cc(623)] Failed to call method: org.freedesktop.ScreenSaver.GetActive: object_path= /org/freedesktop/ScreenSaver: org.freedesktop.DBus.Error.NotSupported: This method is not implemented
[13722:13722:0122/110937.457373:ERROR:object_proxy.cc(623)] Failed to call method: org.gnome.ScreenSaver.GetActive: object_path= /: org.freedesktop.DBus.Error.UnknownMethod: Object does not exist at path “/”
[13722:13782:0122/110938.191293:ERROR:chrome_browser_main_extra_parts_metrics.cc(227)] START: ReportBluetoothAvailability(). If you don't see the END: message, this is crbug.com/1216328.
[13722:13782:0122/110938.191332:ERROR:chrome_browser_main_extra_parts_metrics.cc(230)] END: ReportBluetoothAvailability()
^C% 

However, as I said in my original post Chrome fires up in less than 5 seconds, while Firefox takes almost 1 whole minute to launch.

Try disabling Hardware acceleration in Setttings > General > Performance > uncheck “Use recommended performance settings” > uncheck “Use hardware acceleration when available”.

You can also try to launch firefox with a new profile to see if this still happens or refresh firefox:

So both firefox -safe-mode and disabling the hardware acceleration had no change. Both times Firefox still took almost 1 minute to startup.

If I understand, safe-mode has everything disabled automatically, so ‘refreshing’ or disabling all my extensions I think would basically be the same exercise as -safe mode…if I am understanding it correctly.

Any other things to try?

  • In the URLBar type about:about and select about:performance (or type it directly), this will bring up a Task Manager. Check to see if anything stands out.
  • ctrl-shift-delete and remove cache or goto about:support
  • Try a new profile
  • And if we missed anything, try → Firefox takes a long time to start up | Firefox Help