Firefox "Secure Connection failed"

So I got Manjaro installed and the cursor issued fixed now Firefox is giving me a Secure Connection failed error for most website. But I can get to Google and pacman is working fine so connectivity is there.

Check that your system clock has got the correct time.

1 Like

That was part of my initial setup before I installed the OS.

I know - but it is one of the reasons why secure connections can fail.

It was the low hanging fruit.

… no, I am not competent enough to debug this what is a very weird error to have on a fresh installation :man_shrugging:

That may be true, but the question is:
Does it show the right time right now?

Did you play around in about:config with this setting?:


It should be set to true. Is the system fully updated? There was an openssl update yesterday on Unstable branch.

Is it only FF or does this issue occur with Chromium based browser(s)? Does it occur with a fresh profile and no extensions or in FF safe mode?

1 Like

So yes the system was installed yesterday and that seems to be part of the issue. However I went back and doubled checked my bios settings somehow the clock was off. Don’t know how that happened as it was one of the first things I set when I build a new system. Now things are moving right along and the machine is working as expected. Thank you for all the help.

1 Like

On some ISO the systemd-timesyncd.service is not enabled after installation

sudo systemctl enable --now systemd-timesyncd
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.