Firefox not starting

I’m new to manjaro and I would like to run Firefox browser. However I get an error message that another instance is already running, what is not true.

After reading on forum/internet i have to set an environement variable in the /etc/environment file as following:

I reboot system and tried again, but I still have the same issue.
So what did I do wrong ?


Did you try with a fresh profile?

Hi @alain.roger, and welcome!

In addition to

…how did you install it? I’m using Firefox Developer edition without any problems.

This is a fresh installation of Manjaro with a fresh profile. I worked under Ubuntu for 7 years without having such issue so I do not understand what is the issue. I installed FF using sudo pacman -Syu firefox.

I even tried to downgrade it as some posts on internet suggested it, but nothing works.


Can you start firefox on console: firefox ?

1 Like

I installed FF using standard way so sudo pacman -Syu firefox

Installed version is 102.0.1

I was able to install nvidia driver, opencl driver, vivaldi,and a lot of over apps without any issue.

Only firefox say that another instance is running while ps -ef | grep firefox display no running process including firefox (except the grep)
2022-07-07_FF issue-ps results

Here is my environment variable file
2022-07-07_FF issue-environment variable

same result in console or via app launcher icon…
2022-07-07_FF issue

Have you followed all the steps on Mozilla’s support page: “Firefox is already running but is not responding” error - How to fix?

You should make sure that no Firefox processes are running before you remove any lock files from your profile & do any other steps such as setting directory permissions.

You can try launching Firefox in terminal with firefox -p.
This opens the chooser - and from here, instead of your main profile, I suggest you create a new profile - call it alain maybe.

If that works, then there is something wrong with the old profile folder - but you can still recover some data from there, or by simply synchronising the new one.

While you’re there, check for ‘lock’ files which block multiple instances of Firefox on the same profile - if you close Firefox but this file still exists, then Firefox sees that file as evidence there’s still a Firefox running… it’s a dumb check :wink: not smart.


Thanks Ben,

that was a smart step.
I created a brand new profile and firefox starts without any issue.

after checking profile permissions I just discovered that on both profiles by default where owned by root while they should be on my user (so “alain”)

Now everything works well


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.